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1.  PanPhaseDiagram 

Example 1.1 Al-Mg Binary Phase Diagram 

Purpose: Learn to calculate and use a binary phase diagram 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.1.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1, and 

select Al and Mg two components;  

 Perform 2D calculation following the procedure in Pandat User’s Guide 3.3.3; 

 Set Calculation Condition as shown in Figure 1.1.1; 

 

Figure 1.1.1: 2D calculation with composition from pure Al to pure Mg and 
temperature from 0oC to 800oC 
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Post Calculation Operation: 

 Label phase field following the procedure in Pandat User’s Guide 2.3.3; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Zoom the interested area following the procedure in Pandat User’s Guide 2.3.3; 

 
Figure 1.1.2: Calculated Al-Mg binary phase diagram 

 

Information obtained from this calculation: 

 Phase stability as a function of composition and temperature; 

 Congruent melting temperature and composition of a phase. For example the 

congruent melting temperature of the AlMg_Gamma phase is at 463.3oC and 

x(Mg)=0.537; 

 Invariant reaction temperatures and phase compositions. For example the three 

phase equilibrium: Liquid->AlMg_Gamma+Hcp is at 436oC, the composition, 

x(Mg), of each phase at equilibrium is indicated in Figure 1.1.2. Details on the 

invariant reactions can be found in the “invariant” table as shown in Figure 

1.1.3, and composition of each phase involved in the invariant reaction can be 

found in the “invariant_tieline” tables as shown in Figure 1.1.4.  
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Figure 1.1.3: The invariant table showing all the three-phase equilibrium in the Al-Mg 
binary system 

 

 
Figure 1.1.4: The invariant_tieline table showing the composition of each phase 

involved in the invariant reaction in the Al-Mg binary system 
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Example 1.2 Phase Fraction as a Function of Composition 

Purpose: Learn to calculate and use a phase fractions vs. composition plot 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Figure 1.2.1 is the Al-Mg binary phase diagram, which clearly shows the single phase 

region, two-phase region, three-phase equilibrium. However if you want to know the 

fraction of a stable phase in a two-phase field at a certain temperature, you need to 

draw a horizontal line at this temperature and calculate it by lever rule. In this 

example, we calculate the fraction of each phase as a function of composition, x(Mg), 

at 300oC (the red dash line). 

 
Figure 1.2.1: Al-Mg binary phase diagram 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.2.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1, and 

select Al and Mg two components;  

 Perform 1D calculation following the procedure in Pandat User’s Guide 3.3.2; 
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 Set Calculation Condition as shown in Figure 1.2.2; 

 

 

Figure 1.2.2: 1D calculation from pure Al to pure Mg at 300oC  

 

Post Calculation Operation: 

 Add legend for graph following the procedure in Pandat User’s Guide 2.3.3; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 The composition range that a phase is stable at the selected temperature; 

 In a single phase field, the fraction of the stable phase is 1; 

 In a two-phase field, the fraction of one phase decrease from 1 to 0, while the 

other increase from 0 to 1 as shown in Figure 1.2.3; 

 Details on the fraction of each phase as a function of composition can also be 

found in the Default table as shown in Figure 1.2.4; 
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Figure 1.2.3: Phase fraction variation as a function of composition 

 

 

Figure 1.2.4: Default table showing phase fraction variation as a function of 
composition 

  



PandatTM 2020 Example Book 

~ 7 ~ 
 

Example 1.3 Phase Fraction as a Function of Temperature 

Purpose: Learn to calculate and use a phase fractions vs. temperature plot 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

In Example 1.2, we have calculated the fraction of each phase as a function of 

composition. In most cases, people would like to know phase transformation when 

temperature varies. In this example, we calculate the fraction of phases as a function 

of temperature for an alloy with 70 at% Al and 30 at% Mg (the red dash line in Figure 

1.3.1). Such a calculation is especially valuable for a multi-component alloy. 

 
Figure 1.3.1: Al-Mg binary phase diagram 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.3.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform 1D calculation following the procedure in Pandat User’s Guide 3.3.2; 
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 Set Calculation Condition as shown in Figure 1.3.2; 

 

 
Figure 1.3.2: 1D calculation from 700oC to 0oC for alloy with 70 at% Al and 30 at% Mg 

 

Post Calculation Operation: 

 Add legend to the graph following the procedure in Pandat User’s Guide 2.3.3; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 

Information obtained from this calculation: 

 Liquid is the only stable phase at high temperature until 496.1oC, which is the 

liquidus temperature; 

 Below liquidus, Fcc phase forms and its fraction increases while that of the 

Liquid phase decreases until the eutectic temperature 450.47oC; 

 At eutectic temperature 450.47oC, Liquid is disappeared (drops to 0% from 

68.3%), fraction of the AlMg_Beta phase jumps from 0% to 60.21% and that of 

the Fcc phase jumps from 31.7% to 39.79%; 

 Details on the fraction of each phase as a function of temperature can be found 

in the Default table as shown in Figure 1.3.4; 
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Figure 1.3.3: Phase fraction variation as a function of temperature 

 

 
Figure 1.3.4: Default table showing details of phase fraction variation as a function of 

temperature 
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Example 1.4 Point Calculation at Fixed Temperature and Composition 

Purpose: Learn to calculate and get detailed phase stability information at a given 

temperature and composition 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

From the Al-Mg phase diagram shown in Figure 1.4.1, we know that two phases, 

AlMg_Beta+Fcc, are stable at the point indicated by  (the cross of the two dash lines). 

Other than that, no detail information about this point can be read directly from this 

phase diagram. In this example, we perform a Point Calculation to obtain the detail 

information at the selected point.  

 
Figure 1.4.1: Al-Mg binary phase diagram 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.4.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform 0D calculation following the procedure in Pandat User’s Guide 3.3.1; 

 Set Calculation Condition as shown in Figure 1.4.2; 
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Figure 1.4.2: Point Calculation for an alloy with 30 at% Al and 70 at% of Mg at 300oC 

Calculation Method 3:  

 After the Al-Mg phase diagram is calculated, click on the Labeling mode, 

then put the cursor at the selected point and press Ctrl button, click the mouse;  

Information obtained from this calculation: 

 Two phases, AlMg_Gamma and Hcp, are stable at the given condition 

(temperature and composition); 

 The G, H, S, and Cp of the system at the given composition and temperature 

are 22744.9J/mol, 6539.3J/mol, 51.0935J/K•mol, and 30.2876J/K•mol, 

respectively; 

 The equilibrium composition of AlMg_Gamma is x(Al) = 0.409686, x(Mg) = 

0.590314; 

 The mole fraction of AlMg_Gamma is 0.687999 (weight fraction is 0.696044); 

 The G, H, Cp, Gex, and Hex of AlMg_Gamma at equilibrium composition are 

23186.3 J/mol, 5976.71 J/mol, 31.3752 J/K•mol, 135.828 J/mol, and 146.6 

J/mol, respectively; 

 The site fraction of AlMg_Gamma are: 𝑦𝑀𝑔
𝐼 = 1, 𝑦𝐴𝑙

𝐼𝐼 = 0.0291951, 𝑦𝑀𝑔
𝐼𝐼 = 0.970805, 

𝑦𝐴𝑙
𝐼𝐼𝐼 = 0.96088, 𝑦𝑀𝑔

𝐼𝐼𝐼 = 0.0391201; 

 The equilibrium composition of Hcp is x(Al) = 0.058129, x(Mg) = 0.941871; 

 The mole fraction of Hcp phase is 0.312001 (weight fraction is 0.303956); 
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 The G, H, Cp, Gex, and Hex of Hcp at equilibrium composition are 21771.6 

J/mol, 7779.87 J/mol, 27.8893 J/K•mol, 179.735 J/mol, and 184.813 J/mol, 

respectively; 

 The site fraction of Hcp is the same as its composition since it is essentially one 

sublattice model, the second sublattice is occupied by vacancy 

 

 
Figure 1.4.3: Calculated results for an alloy with 30 at% Al and 70 at% of Mg at 300oC 
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Example 1.5 Isotherm of Al-Mg-Zn at 500oC 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Purpose: Learn to calculate and use an isothermal section in a ternary system 

A complete phase diagram of a ternary system should be described by a triangular 

prism in a 3D space with each edge of the triangle base representing the composition 

axis of each component and the vertical axis the temperature. Due to the complexity of 

many ternary systems, phase stability of a ternary system is usually described by 

Isothermal sections parallel to the triangle base (constant temperature) and isoplethal 

sections vertical to the triangle base plane. In this example, we will calculate an 

isothermal section of Al-Mg-Zn at 500oC. 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.5.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1, and 

select all three elements;  

 Perform 2D calculation following the procedure in Pandat User’s Guide 3.3.3; 

 Set Calculation Condition as shown in Figure 1.5.1; 

 
Figure 1.5.1: 2D calculation of an isotherm of Al-Mg-Zn at 500oC 
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Post Calculation Operation: 

 Label phase field following the procedure in Pandat User’s Guide 2.3.3; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add tie-lines  following the procedure in Pandat User’s Guide 2.3.1; 

 
Figure 1.5.2: Calculated isotherm of Al-Mg-Zn at 500oC 

 

Information obtained from this calculation: 

 Phase stability in different composition areas, single phase, two-phase, and 

three-phase regions, can be viewed clearly at this temperature;  

 Equilibrium between two phases is connected by tie-lines, and the equilibrium 

compositions of the two phases can be read at the end points of the tie-line; 

Details on the tie-lines can be found in Table->tieline as shown in Figure 1.5.3. 

In this table, the compositions of the two phases connected by each tieline are 

listed for all the calculated tielines; 
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 Three-phase equilibrium is shown by the tie-triangle. The composition of each 

phase in the three-phase equilibrium is listed in invariant_tieline table, as 

shown in Figure 1.5.4. 

 

 
Figure 1.5.3: The tieline table showing the detailed information of calculated tieline 

 

 
Figure 1.5.4: The invariant_tieline table showing the composition of each phase in the 

invariant reaction 
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Example 1.6 Isopleth of Al-Mg-Zn at 15 at% Zn 

Purpose: Learn to calculate and use an isoplethal section in a ternary system 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

As mentioned in Example 1.5, isopleths are sections vertical to the triangle base plane 

of the triangular prism. An isopleth is important in understanding phase relationship 

in a ternary system when temperature is a variable. In this example, we will calculate 

an isoplethal section in the Al-Mg-Zn ternary parallel to Al-Mg binary with 15 at% of 

Zn. 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.6.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform 2D calculation following the procedure in Pandat User’s Guide 3.3.3; 

 Set Calculation Condition as shown in Figure 1.6.1; 

 
Figure 1.6.1: 2D calculation of an isopleth parallel to Al-Mg binary with 15 at% Zn 
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Post Calculation Operation: 

 Label phase field following the procedure in Pandat User’s Guide 2.3.3; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 
Figure 1.6.2: Calculated isopleth parallel to Al-Mg binary with 15 at% Zn 

 

Information obtained from this calculation: 

 Phase stability as a function of composition of Mg and temperature. Single 

phase, two-phase, and three-phase regions, can be viewed clearly at different 

composition and temperature;  

 Tie-lines cannot be viewed on an isopleth since they are usually not on the 

same isoplethal plane except for a pseudo-binary. The tieline information is 

listed in tieline Table as shown in Figure 1.6.3. 

 The invariant reactions and the phase composition for every phase in the 

invariant reaction are listed in invariant_tieline table as shown in Figure 1.6.4. 
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Figure 1.6.3: The tieline table showing the detailed information of calculated tieline 

 

 
Figure 1.6.4: Invariant_tieline table showing composition of each phase involved in the 

invariant reaction 
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Example 1.7 Liquidus Projection of Al-Mg-Zn 

Purpose: Learn to calculate and use a liquidus projection in a ternary system 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

As shown in Example 1.5 and Example 1.6, isotherms and isopleths are two types of 

phase diagrams used to view the phase relationship in a ternary system. Another type 

of phase diagrams commonly used to understand a ternary system is the liquidus 

projection which is the projection of the liquid surface onto the base triangle plane. In 

this example, we will calculate the liquidus projection of Al-Mg-Zn ternary system. 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.7.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform 2D calculation following the procedure in Pandat User’s Guide 3.3.5; 

 Set Calculation Condition as shown in Figure 1.7.1; 

 
Figure 1.7.1: Calculation of liquidus projection of the Al-Mg-Zn system 
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Post Calculation Operation: 

 Label phase field following the procedure in Pandat User’s Guide 2.3.3; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label the isothermal lines by put the cursor on each line and then press F2; 

 
Figure 1.7.2: Calculated liquidus projection of the Al-Mg-Zn system 

Information obtained from this calculation: 

 The phase name labeled in each region indicates the primary solidified phase 

from liquid when the given alloy composition falls in that region; 

 The univariant liquid projection lines (blue lines) trace the composition of the 

liquid phase for the three-phase equilibrium among the liquid and the other two 

phases separated by the liquid projection line; 

 The isothermal lines (from red to green with temperature descending) represent 

the liquidus temperatures. The liquidus temperature for all the compositions 

along each line is identical; 

 Each triple point at the intersection of three projection lines represents a 

invariant reaction (four phases in a ternary system) involving the liquid phase. 
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All the invariant reactions are listed in invariant table as shown in Figure 1.7.3. 

The composition of each phase involved in the invariant reaction is listed in 

invariant_tieline table as shown in Figure 1.7.4.  

 
Figure 1.7.3: Invariant table showing all the invariant reactions involving liquid phase 

 

 
Figure 1.7.4: Invariant_tieline table showing composition of each phase involved in the 

invariant reaction 
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Example 1.8 Solidification Simulation by Scheil Model and Lever Rule 

Purpose: Learn to perform solidification simulation for a given alloy composition 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Pandat has two models for solidification simulation, one based on Lever rule and the 

other Scheil model. Lever rule assumes infinite slow cooling so that equilibrium is 

reached at every step of solidification. Scheil model assumes fast cooling and fast 

diffusion in the liquid so that liquid maintains uniform composition, no diffusion in 

the solid and local equilibrium is reached between liquid and solid at the interface. In 

this example we will perform two solidification simulations using the two models for 

an alloy with 40 at% of Al, 50 at% of Mg and 10 at% of Zn. We will then compare the 

simulation results by plotting them on the same plot. 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.8.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform solidification simulation following the procedure in Pandat User’s 

Guide 3.3.6; 

 Set Calculation Condition as shown in Figure 1.8.1, check “Scheil” for the first 

calculation and “Lever” for the second calculation 

 
Figure 1.8.1: Input the alloy composition for solidification simulation 
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Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add text and arrow on the plot following the procedure in Pandat User’s Guide 

2.3.3; 

Information obtained from this calculation: 

 Figure 1.8.2 shows the fraction of solid as a function of temperature from Scheil 

simulation. Solidification starts at 457oC and ends at 336.9oC, the freezing 

range is 120.1oC;   

 The primary solidified phase is T_AlMgZn phase, AlMg_Gamma starts to solidify 

at 447.5oC and Hcp starts to solidify at 351.8oC. Put the cursor on the line 

segment, a tool tip will pop out showing the phase(s) solidified in that 

composition and temperature range (Figure 1.8.2). Press ‘F2’ to label it; 

 Detail information for the simulation, such as solidification start temperature 

for a certain phase, the total fraction of each solid at different temperatures, 

latent heat, and total heat evolved can be found in the Default Table as shown 

in Figure 1.8.3; 

 Certain properties can be selected from the Default table and plotted. Figure 

1.8.4 shows the fraction of each solid phase as a function of temperature, and 

Figure 1.8.5 shows the Latent heat and total heat evolution as a function of 

temperature; 

 Figure 1.8.6 shows the lever rule simulation which follows equilibrium 

calculation. It therefore shows a very narrow solidification range, starting from 

457oC and ending at 437oC; 

 Only two phases solidified from lever rule simulation, i.e., T_AlMgZn phase and 

AlMg_Gamma phase; 

 Details on the fraction of solid phase, heat evolution, and so on can also be 

found in the Default table; 

 Figure 1.8.7 shows the overlapped plots from Scheil simulation and Lever rule 

simulation. To merge two plots together, we first open the plot from Lever rule 

simulation as shown in Figure 1.8.6, right click the mouse and choose “Copy 

Data”, then open the plot from Scheil simulation as shown in Figure 1.8.2, 

right click the mouse and choose “Paste Data”. The two plots from Lever rule 

simulation and Scheil simulation are merged in the same diagram as shown in 

Figure 1.8.7; 
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Figure 1.8.2: Fraction of solid as a function of temperature from Scheil simulation  

 

 
Figure 1.8.3: Detailed solidification information listed in the Default table 
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Figure 1.8.4: Fraction of each solid phase as a function of temperature 

 
Figure 1.8.5: Heat evolution as a function of temperature 
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Figure 1.8.6: Fraction of solid as a function of temperature by Lever rule simulation  

 
Figure 1.8.7: Merge the Scheil and Lever simulation results together 
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Example 1.9 Calculation of Gibbs Energy Curves 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Purpose: Learn to calculate the Gibbs energy of a system or individual phase 

Figure 1.9.1 is the Al-Mg binary phase diagram. In this example, we learn to calculate 

the Gibbs energy of the system and the Gibbs energy of each phase as a function of 

composition, x(Mg), at 300oC (the red dash line). 

 
Figure 1.9.1: Al-Mg binary phase diagram 

 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.9.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “Property” on the menu bar and select “Thermodynamic Property”; 
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 Set Calculation Condition as shown in Figure 1.9.2. The property selected is G, 

and the reference states are set as Fcc for Al and Hcp for Mg, the Gibbs energy 

of the system (stable phases in each composition range) will be calculated as 

shown by Figure 1.9.4; 

 If the “Individual Phases” is checked, and G(@*) is selected instead of G, the 

Gibbs energy curve of every phase as a function of composition will be 

calculated as shown by Figure 1.9.5; 

 

 
Figure 1.9.2: Calculation of the Gibbs energy for individual phases or the system from 

“Property” calculation 

 

Calculation Method 3:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “PanPhaseDiagram” on the menu bar and select “Line Calculation”; 

 Set Calculation Condition as shown in Figure 1.9.3, check the “Individual 

Phases”; 
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Figure 1.9.3: Calculation of the Gibbs energy for individual phases by Line calculation  

 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add text and arrow on the plot following the procedure in Pandat User’s Guide 

2.3.3; 

Information obtained from this calculation: 

 Figure 1.9.4 shows the Gibbs energy of the system as a function of x(Mg), i.e., 

the Gibbs energy at each composition represents the Gibbs energy of the stable 

phase(s) at that composition; 

 Figure 1.9.5 shows the Gibbs energy curve of every individual phase as a 

function of x(Mg) 

 Detail Gibbs energy values can be found in the “thermodynamic property” table 
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Figure 1.9.4: Calculated Gibbs energy of the system  

 
Figure 1.9.5: Calculated Gibbs energy of each individual phase by Line calculation 
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Example 1.10 Calculation of Activity at Constant Temperature 

Purpose: Learn to calculate activities of components in a system 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Figure 1.10.1 is the Al-Mg binary phase diagram. In this example, we learn to 

calculate the activity of Al and Mg as a function of x(Mg) at 300oC (the red dash line). 

 
Figure 1.10.1: Al-Mg binary phase diagram 

 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.10.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “Property” on the menu bar and select “Thermodynamic Property”; 
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 Set Calculation Condition as shown in Figure 1.10.2. The property selected is 

a(*), and the reference states are set as Fcc for Al and Hcp for Mg; (*) means the 

activity of every component (both Al and Mg in this case) 

 

 
Figure 1.10.2: Calculation of the activity of Al and Mg from “Property” calculation 

Calculation Method 3:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “PanPhaseDiagram” on the menu bar and select “Line Calculation”; 

 Add the new table following the procedure in Pandat User’s Guide 2.4.1; 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add text and arrow on the plot following the procedure in Pandat User’s Guide 

2.3.3; 

Information obtained from this calculation: 

 Figure 1.10.3 shows the activities of Al and Mg as a function of x(Mg) using Fcc 

Al and Hcp Mg as reference states;  
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 Activity of Al is 1 at x(Al)=1 (x(Mg)=0) since it is pure Fcc Al at this temperature 

and Fcc is used as the reference state; Activity of Al decreases with the increase 

x(Mg) and becomes zero at x(Mg)=1; 

 Activity of Mg is 0 at x(Al)=1 (x(Mg)=0) and increases with the increase x(Mg) 

and becomes 1 at x(Mg)=1; 

 Activity of either component is constant in a two-phase field 

 
Figure 1.10.3: Activities of Al and Mg in Al-Mg binary at 300oC 
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Example 1.11 Calculation of Activity at Constant Composition 

Purpose: Learn to calculate activities of components as a function of temperature 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Figure 1.11.1 is the Al-Mg binary phase diagram. In this example, we learn to 

calculate the activity of Al and Mg as a function of temperature at a fixed composition 

(the red dash line). 

 
Figure 1.11.1: Al-Mg binary phase diagram 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.11.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “Property” on the menu bar and select “Thermodynamic Property”; 
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 Set Calculation Condition as shown in Figure 1.11.2. The property selected is 

a(*), and the reference states are set as Liquid for both Al and Mg; 

 

 
Figure 1.11.2: Calculation of the activity of Al and Mg from “Property” calculation 

Calculation Method 3:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “PanPhaseDiagram” on the menu bar and select “Line Calculation”; 

 Add the new table following the procedure in Pandat User’s Guide 2.4.1; 

Information obtained from this calculation: 

 Figure 1.11.3 shows the activities of Al and Mg as a function of temperature 

using Liquid Al and Liquid Mg as reference states; 

 In the Liquid phase field at high temperature, activities of both Al and Mg 

decrease as temperature decreases; 

 In the Fcc+Liquid two-phase field, the activity of Al decreases as temperature 

decreases, but the activity of Mg increases as temperature decreases. This is 

because in this two-phase field the activity of each component follows its 

activity along the liquidus line. The composition of Mg increases along the 

liquidus line with decreasing temperature, which makes its activity increase; 
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 In the AlMg_Beta+Fcc two-phase field, activities of both Al and Mg decrease 

with the decrease of temperature refer to the Liquid Al and Mg reference states;  

 
Figure 1.11.3: Activities of Al and Mg at 70% at% Al and 30 at% Mg as a function of 

temperature 
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Example 1.12 Calculation of Molar Volume and Density at Fixed Temperature 

Purpose: Learn to calculate physical properties in a system 

Module: PanPhaseDiagram 

Database: AlMg_MV.tdb 

Figure 1.12.1 is the Al-Mg binary phase diagram. In this example, we learn to 

calculate the molar volume and density of the system as a function of x(Mg) at 300oC 

(the red dash line). 

 
Figure 1.12.1: Al-Mg binary phase diagram 

 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.12.pbfx; 

Calculation Method 2:  

 Load AlMg_MV.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “Property” on the menu bar and select “Physical Property”; 

 Set Calculation Condition as shown in Figure 1.12.2. The property selected is 

Vm (molar volume) and density 
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Figure 1.12.2: Setup calculation of molar volume and density from pure Al to pure Mg 

at 300oC 

Calculation Method 3:  

 Load AlMg_MV.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “PanPhaseDiagram” on the menu bar and select “Line Calculation”; 

 Add the new table following the procedure in Pandat User’s Guide 2.4.1, and 

select Table Type as “physical_property”; 

Information obtained from this calculation: 

 Figure 1.12.3 shows the calculated molar volume which increases with the 

increase of Mg content; Figure 1.12.4 is the calculated density which shows the 

opposite trend as that of the molar volume; 

 Details information can be found in the physical_property Table as shown in 

Figure 1.12.5; 
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Figure 1.12.3: Calculated molar volume of the system from pure Al to pure Mg in Al-

Mg binary at 300oC 

 
Figure 1.12.4: Calculated density from pure Al to pure Mg in Al-Mg binary at 300oC 
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Figure 1.12.5: the physical_property table showing the stable phases varying with the 

composition and the calculated molar volume and density 
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Example 1.13 Calculation of Molar Volume and Density at Fixed Composition 

Purpose: Learn to calculate physical properties in a system 

Module: PanPhaseDiagram 

Database: AlMg_MV.tdb 

Figure 1.13.1 is the Al-Mg binary phase diagram. In this example, we learn to 

calculate the molar volume and density of the system as a function of temperature at a 

fixed composition (the red dash line). 

 
Figure 1.13.1: Al-Mg binary phase diagram 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.13.pbfx; 

Calculation Method 2:  

 Load AlMg_MV.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “Property” on the menu bar and select “Physical Property”; 
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 Set Calculation Condition as shown in Figure 1.13.2. The property selected is 

Vm (molar volume) and density 

 
Figure 1.13.2: Setup calculation of molar volume and density from 0 to 800oC at a 

fixed composition 

Calculation Method 3:  

 Load AlMg_MV.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click “PanPhaseDiagram” on the menu bar and select “Line Calculation”; 

 Add the new table following the procedure in Pandat User’s Guide 2.4.1, and 

select Table Type as “physical_property”; 

Information obtained from this calculation: 

 Figure 1.13.3 shows the calculated molar volume which increases with the 

increase of temperature; Figure 1.13.4 is the calculated density which shows 

the opposite trend as that of the molar volume; 

 Details information can be found in the physical_property Table; 
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Figure 1.13.3: Calculated molar volume of the system in Al-Mg binary from 0 to 800oC 

at a fixed composition 

 

 
Figure 1.13.4: Calculated density of the system in Al-Mg binary from 0 to 800oC at a 

fixed composition 
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Example 1.14 Density Contour Diagram 

Purpose: Learn to calculate density contour diagram. In this example, the density 

contour lines will be plotted in the Al-Mg binary phase diagram so that density at 

different temperatures and compositions can be viewed together with phase stability. 

Module: PanPhaseDiagram 

Database: AlMg_MV.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.14.pbfx; 

Calculation Method 2:  

 Load AlMg_MV.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 First set up the calculation condition as shown in Figure 1.14.1 in the same 

way as we did to calculate Al-Mg binary phase diagram (see Example_#1), then 

click “Contour Lines” to open the contour line dialog as shown in Figure 1.14.2; 

 Choose “User Custom Type” and click Add. Type in “density” for the Contour 

Type in the “Properties” window as shown in Figure 1.14.2, then press OK; 

 
Figure 1.14.1: Setup calculation for the Al-Mg binary phase diagram, then press 

“Contour Lines” 
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Figure 1.14.2: Type in “density” for the Contour Type in the “Properties” window 

 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label each line by putting the cursor on each line and wait for the tool tip to 

pop out, then press F2; 

Information obtained from this calculation: 

 Figure 1.14.3 shows the density contour diagram, i.e., plotting density contour 

lines on top of the Al-Mg binary phase diagram. The density on the same red 

line is constant; 

 Density contour diagram is very useful in alloy design. Given the requirements 

on stable phases and alloy density, the alloy compositions can be identified 

from this one diagram; 
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Figure 1.14.3: Density contour diagram for the Al-Mg binary system 
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Example 1.15 Activity Contour Diagram 

Purpose: Learn to calculate activity contour diagram. In this example, the activity 

contour lines of Mg will be calculated and plotted on the isothermal section of the Al-

Mg-Zn ternary system at 500oC. 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.15.pbfx; 

Calculation Method 2:  

 Load AlMgZn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 First set up the calculation condition as shown in Figure 1.15.1 in the same 

way as we did to calculate Al-Mg-Zn isotherm (see Example_#5), then click 

“Contour Lines” to open the contour line dialog as shown in Figure 1.15.2; 

 Choose “User Custom Type” and click Add. Type in “a(Mg:Hcp)” for the Contour 

Type in the “Properties” window as shown in Figure 1.15.2, then press OK; 

 
Figure 1.15.1: Setup calculation for an isotherm in the Al-Mg-Zn ternary at 500oC, 

then press “Contour Lines” 
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Figure 1.15.2: Type in “a(Mg:Hcp)” for the Contour Type in the “Properties” window, it 

is to calculate the activity of Mg contour lines using Hcp Mg as reference state 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label each line by putting the cursor on each line and wait for the tool tip to 

pop out, then press F2; 

Information obtained from this calculation: 

 Figure 1.15.3 shows the activity contour diagram of Mg at 500oC. The variation 

of Mg activity in the composition triangle is clearly seen at this temperature;  

 Activity contour lines can also be plotted only in the selected phase field, such 

as in the Liquid phase field, in the Liquid+Fcc phase field. An example is given 

in Pandat User’s Guide 3.3.4; 
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Figure 1.15.3: Activity contour diagram of Mg in the Al-Mg-Zn ternary at 500oC 
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Example 1.16 Pressure Contour Diagram 

Purpose: Learn to calculate pressure contour diagram. In this example, the pressure 

contour lines of total pressure and partial pressure of N2 in the Ti-N system will be 

calculated and plotted on the Ti-N binary phase diagram. 

Module: PanPhaseDiagram 

Database: TiN_Gas_Pressure.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.16.pbfx; 

Calculation Method 2:  

 Load TiN_Gas_Pressure.tdb following the procedure in Pandat User’s Guide 

3.2.1;  

 First set up the calculation condition as shown in Figure 1.16.1 for calculating 

Ti-N binary phase diagram, then click “Contour Lines” to open the contour line 

dialog as shown in Figure 1.16.2; 

 Choose “User Custom Type” and click Add. Type in “log(P(@gas))” for the 

Contour Type in the “Properties” window as shown in Figure 1.16.2, then OK; 

 
Figure 1.16.1: Setup calculation for Ti-N binary phase diagram, then click Contour 

Lines 
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Figure 1.16.2: Type in “log(P(@gas))” for the Contour Type in the “Properties” window, 

it is to calculate the total pressure contour lines from logP = 10 to 30 with step 2 

 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label each line by putting the cursor on each line and wait for the tool tip to 

pop out, then press F2; 

Information obtained from this calculation: 

 Figure 1.16.3 shows the contour diagram of total pressure in Ti-N system;  

 If we type in “log(P(N2@gas))” as the Contour Type in the “Properties” window in 

Figure 1.16.2, we will obtained the contour diagram for partial pressure logP(N2) 

as shown in Figure 1.16.4; 
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Figure 1.16.3: Calculated contour diagram of total pressure in the Ti-N system 

 
Figure 1.16.4: Calculated contour diagram of partial pressure of N2 in the Ti-N system 
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Example 1.17 3D Diagram 

Purpose: Learn to calculate a 3D diagram. In this example, 3D diagram is calculated 

for a hypothetical ternary system.  

Module: PanPhaseDiagram 

Database: ABC.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.17.pbfx; 

Calculation Method 2:  

 Load ABC.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform Phase Projection calculation following the procedure in Pandat User’s 

Guide 3.3.5; 

 Setup calculation condition as shown in Figure 1.17.1. From this setting, * is 

selected  as Target Phase which means all the phases in the system are selected 

in the calculation; 

 
Figure 1.17.1: Setup calculation for a 3D diagram 
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Post Calculation Operation: 

 In the Property window, under 4: Invariant Tieline Property, choose “True” for 

the Show Invariant Tieline, the invariant reaction lines in the three binaries as 

well as in the ternary will be shown (Figure 1.17.2); 

 Rotate the 3D diagram to a position you like; 

 Add a new Table as shown in Figure 1.17.3 to get the phase boundary data just 

for the BCC phase. Select x(C) as x-axis by selecting this column first, then 

press Ctrl and select x(A) as y-axis, then press Ctrl and select T as z-axis, plot 

3D diagram as shown in Figure 1.17.4; 

 Add a new Table as shown in Figure 1.17.5 to get the isothermal lines just for 

the BCC phase, notice that the Table Type must be “isotherm”; 

 Double click to open the 3D diagram for BCC (Figure 1.17.4), single click the 

table name for the isothermal lines. From the Property window, drag in x(C) first, 

then press Ctrl and drag in x(A), then press Shift and drag in T, the isothermal 

lines for the BCC phase will be plotted on it as shown in Figure 1.17.6; 

 

 
Figure 1.17.2: Calculated 3D diagram for the A-B-C system 
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Figure 1.17.3: Add a new Table to get the phase boundary data just for the BCC phase 

 
Figure 1.17.4: Plot 3D diagram for BCC phase only 
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Figure 1.17.5: Add a new Table to get the isothermal lines just for the BCC phase 

 

 
Figure 1.17.6: 3D diagram for the BCC phase with isothermal lines 
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Example 1.18 Temperature-Pressure Diagram 

Purpose: Learn to calculate a Temperature-Pressure diagram. In this example, a 

Temperature-Pressure diagram is calculated for pure Fe component.  

Module: PanPhaseDiagram 

Database: Fe_Pressure.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.18.pbfx; 

Calculation Method 2:  

 Load Fe_Pressure.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform a Section Calculation from PanPhaseDiagram, and set the calculation 

condition as shown in Figure 1.18.1; 

 
Figure 1.18.1: Setup calculation of T-P diagram for pure Fe, x-axis is P and y-axis is T 
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Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label the graph following the procedure in Pandat User’s Guide 2.3.3; 

Information obtained from this calculation: 

 Figure 1.18.2 shows the default plot when calculation is finished, it is T-

log10(P). It clearly demonstrates the stability of each phase at different 

temperature and pressure;  

 Detailed information on the three-phase reactions, i.e., the temperatures and 

pressures at triple points can be found in the “invariant” table; 

 From Default table, other plots, such as T-P diagram, can be plotted as shown 

in Figure 1.18.3; 

 
Figure 1.18.2: Temperature-log (Pressure) diagram for pure Fe component 
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Figure 1.18.3: Temperature-Pressure diagram for pure Fe component 
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Example 1.19 Phase Fraction Contour Diagram for Ti64 

Purpose: Learn to calculate and plot phase fraction contour diagram in a multi-

component system. In this example, a contour diagram is calculated and plotted for an 

isopleth in the Ti-Al-V-N-O five components system.  

Module: PanPhaseDiagram 

Database: PanTi2020.pdb (this database is a thermodynamic database for multi-

component titanium alloys which is only available to users who have licensed it) 

Calculation Method 1:  

 Load PanTi2020.pdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform a Section Calculation from PanPhaseDiagram, and set the calculation 

condition as shown in Figure 1.19.1; 

 Click “Contour Lines” in the dialog shown in Figure 19.1, then set the Contour 

Type as shown in Figure 1.19.2; 

 
Figure 1.19.1: Setup a calculation for an isopleth along Ti-Al side with fixed V, O, and 

N compositions 
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Figure 1.19.2: Setup contour lines as the fraction of Bcc (β) phase 

 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label the graph following the procedure in Pandat User’s Guide 2.3.3; 

 Label each line by putting the cursor on each line and wait for the tool tip to 

pop out, then press F2; 

Information obtained from this calculation: 

 Figure 1.19.3 shows the isopleth Ti-Al-4V-0.1O-0.02N (wt%) with contour lines 

of fractions of the β phase. It clearly shows how the fraction of the β phase 

varies with temperature and composition. This plot provides a guidance on the 

selection of alloy composition and heat treatment condition if certain fraction of 

β phase is needed in the microstructure; 

 For Ti64 (6 wt% of Al as indicated by the black dash line), the fraction of β 

 -phase structure can be read from the 

contour diagram directly given a heat treatment temperature; 
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Figure 1.19.3: Contour diagram of the β phase fraction on the isopleth of Ti-Al-4V-

0.1O-0.02N (wt%) 
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Example 1.20 Phase Forming Driving Force in High Entropy Alloys 

Purpose: Learn to calculate and plot driving force contour lines on a multi-component 

phase diagram. Figure 1.20.1 shows an isopleth of CoCrFeNiAlxCoCrFeNi which 

indicates that addition of Al promotes the formation of Bcc and B2. However, it does 

not tell which phase has higher thermodynamic driving force at different temperature 

and composition. In this example, the driving force contour lines for B2 and Bcc are 

plotted on the Liquid+Fcc diagram in the Al-Co-Cr-Fe-Ni system to view the driving 

force of forming B2 and Bcc in this system  

Module: PanPhaseDiagram 

Database: PanHEA.pdb (this database is a thermodynamic database for high entropy 

alloys which is only available to users who have licensed it) 

 
Figure 1.20.1: Calculated isopleth of the CoCrFeNiAlxCoCrFeNi with x=0~2 

Calculation Method 1:  

 Load PanHEA2020.pdb following the procedure in Pandat User’s Guide 3.2.1;  

 Perform a Section Calculation from PanPhaseDiagram, and set the calculation 

condition as shown in Figure 1.20.2; 

 Click “Select Phases” and set status of each phase as shown in Figure 1.20.3; 

 Click “Contour Lines” and then set the Contour Type as shown in Figure 1.20.4 

to calculate the driving force contour lines for B2 phase, click OK; 
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 Click “Contour Lines” and then set the Contour Type as shown in Figure 1.20.5 

to calculate the driving force contour lines for Bcc phase, click OK; 

 

 
Figure 1.20.2: Setup calculation for the isopleth CoCrFeNiAlxCoCrFeNi 

 
Figure 1.20.3: Fcc and Liquid are selected to enter the calculation, B2 and Bcc are 
dormant in the calculation, but their driving force to become stable phases can be 

calculated 
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Figure 1.20.4: Setup calculation of driving force contour lines for B2 phase 

 

 
Figure 1.20.5: Setup calculation of driving force contour lines for Bcc phase 
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Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Label the graph following the procedure in Pandat User’s Guide 2.3.3; 

 Label each line by putting the cursor on each line and wait for the tool tip to 

pop out, then press F2; 

Information obtained from this calculation: 

 After operation of Figure 1.20.4, a diagram with driving force contour lines of 

B2 will be plotted, and after operation of Figure 1.20.5, a diagram with driving 

force contour lines of Bcc will be plotted; 

 To merge the two plots together by choose one of the diagram, say the one with 

Bcc contour lines, to be shown in the main display window, then single click 

Table->Contour_DF(@!B2) table, drag x%(Al) to the main display window, then 

press Ctrl and drag T to the main display window; 

 The merged diagram is shown in Figure 1.20.6. From this figure it is seen that 

at low Al composition, neither B2 or Bcc has the driving force to form (negative 

driving force); with high Al composition, both phases have the driving force to 

form, and B2 has higher driving force than that of the Bcc phase; 

 

 
Figure 1.20.6: Driving force contour diagram for both Bcc and B2 phases 
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Example 1.21 User-defined Property  

Purpose: Learn to define any property in a database in a format similar to that of the 

Gibbs energy and plot the contour lines of the defined property on a multi-component 

phase diagram.  

Module: PanPhaseDiagram 

Database: AlNi_U.tdb 

The molar volume of Al-Ni binary system is taken as an example here. Instead of using 

the specific variable Vm for molar volume, we define a property of U to represent the 

molar volume. In the database file (.tdb), first define the property U with the keyword 

“USER_PROPERTY” as 

Type_Definition a USER_PROPERTY U 1 ! 

Then, define the property U as a function of x, the mole fraction, with the keyword 

“VARIABLE X”: 

Type_Definition b GES AMEND_PHASE_DESCRIPTION * VARIABLE_X U ! 

For any phase with such a property U, include “ab” in the phase definition such as in 

“Liquid” phase, 

Phase Liquid %ab 1 1 ! 

The parameters for the property are defined in the format similar to that of the Gibbs 

energy. An example file “AlNi.tdb” is included in the Pandat example folder. A batch 

file “Example_#1.22.pbfx” is also included in the same folder, which produces an 

identical contour diagram as shown in Figure 1.21.1 except that the property name is 

U instead of Vm. It should emphasize again that U can be any property. 

 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#1.21.pbfx; 

Calculation Method 2:  

 Load AlNi_U.tdb and select both components 

 Pop out dialog for Section (2D) Calculation 

 Set up contour lines as Figure 1.21.2 

 Click OK and perform calculation to obtain Figure 1.21.1 
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Figure 1.21.1: Al-Ni binary phase diagram with the calculated contour lines of molar 

volume (cm3/mol). 

 

 
Figure 1.21.2: Setup contour lines for Property U from interface 
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Example 1.22 Run Pandat in Console Mode  

Purpose: Learn to run Pandat in the console mode for the calculation of Al-Mg binary 

phase diagram; 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Calculation Method 1:  

 Double click the batch file Example_#1.22.pbfx; 

Calculation Method 2:  

 Run through a windows (.bat) file, double click the Example_#1.22.bat; 

The content of an example (.bat) file is shown below: 

 

Figure 1.22.1: Example of the (.bat) file for console mode  

 

Note that above figure shows an example windows (.bat) file. There are a few things 

that user needs to make sure before running this example: 

 The full path of “Pandat.exe”. The default path for Pandat 2020 is: “C:\Program 

Files (x86)\CompuTherm LLC\Pandat 2020\bin\Pandat.exe 

 If the batch file (.pbfx) is not in the same folder of the windows (.bat) file, the full 

path of the batch file (.pbfx) needs to be given.  

 The working folder for the console mode must have been created before running 

the windows (.bat) file. Then a Pandat workspace will be created in this folder 

and all simulation results are saved under this workspace. This argument is 

optional and no graph files are generated if the working folder is not given. This 
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will save many computer resources. In general, the user may not pass this 

argument so that only data (.dat) files are generated after each simulation. In 

“Example_#1.22.pbfx”: 

 

<table name="AlMg_PhaseDiagram.dat" source="default">  

 

A table name “AlMg_PhaseDiagram.dat” is given with an extension “.dat” and 

then a data file (.dat) will be created in the same folder as the batch file. User 

may give a full path for the data file in order to save it into a specified folder. 

 The last argument is to control the output level with “1” the default value. The 

value of “2” is for more outputs and “0” for less. 
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Example 1.23 High Throughput Calculation (HTC): Pattern Compositions  

Purpose: Learn to run high throughput calculation; 

Module: PanPhaseDiagram 

Database: AlMgZn.tdb 

Calculation Method: HTC Calculations by Setting Composition Range and Steps 

 Load proper database and choose the Al-Mg-Zn system. 

 Choose the HTC function from the Batch Calc  High Throughput 

Calculation (HTC) (as shown in Figure 1.23.1). 

 

Figure 1.23.1: HTC function under the “Batch Calc” menu 

 

 Choose the calculation type from the drop-down list of HTC pop-up window and 

select “Solidification”. 

 

 

Figure 1.23.2: Dialog to choose calculation type of HTC 
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 Define the compositional space for HTC simulation.  

After choosing the calculation type, a window pops out as shown in Figure 1.23.3. In 

this setting, the compositions of both Mg and Zn vary from 1 to 30 wt.% in a double 

composition loops. The “Steps” is set to 29, which means the composition increases by 

1 wt% at each step. The total number of calculations is 3030=900 in this setting. The 

composition of Al is set as balance by typing “-1” for steps or right-click the row of Al. 

No “Start” or “End” values are required for the balance component, which is Al in this 

case. After setup the compositional space for HTC and choose the proper solidification 

model, user can click “Run HTC” button to perform HTC simulations, which is 900 

calculations in this case. 

 

 

Figure 1.23.3: Dialog to setup compositional space for HTC 

 

 Save the current workspace after all calculations are finished. It is suggested 

that user saves the current workspace immediately after the HTC calculation. 

This allows all the calculated results saved in the workspace for future use. 
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 Choose “Result Analysis” from the “Batch Calc” menu. User can use this 

commend to analyze the calculated results for a group of alloys and pick a 

certain property from each calculation for comparison. 

 

 

Figure 1.23.4: “Result Analysis” function under the “Batch Calc” menu 

 

 Open the workspace saved previously for “Result Analysis”.  User can perform 

several HTC calculations and save all the workspaces. User can then analyze 

the results of the selected HTC calculation by opening the corresponding 

workspace as shown in Figure 1.23.5. 

 

 

Figure 1.23.5: “Result Analysis” popup dialog to choose target workspace 

 

 Define the criteria of the properties as filters for result analysis.  
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Figure 1.23.6: “Result Analysis” popup dialog to define the criteria of the properties  

 

In Figure 1.23.6, the “Target Workspace” shows the workspace selected by the user for 

results analysis. It should point out that there can be more than one table in each 

calculation, the “Common Tables for All Calculations” allows user to choose the table 

for analysis. In the “Common Columns for the Target Table” window, names for all the 

output properties available in the selected table are listed. User can choose the 

properties to be listed in the “Analysis Report”. As shown in Figure 1.23.6, 

temperature and the alloy composition will be listed in the “Analysis Report” in this 

case. Since the purpose of HTC is to compare a special target property for the several 

hundred/thousands of calculations, the “Set an Expression to Select Rows” at the 

bottom of the window allows user define the criteria. In Figure 1.23.6, this criterion is 

fl=1, i.e. the fraction of liquid is 1. With this filter, only the row satisfies this criterion 

will be listed in the “Analysis Report”.  It should point out that several criteria can be 

set in the “Set an Expression to Select Rows”. Click “Analyze” to create the “Analysis 

Report” as shown in Figure 1.23.7. In this table, each row lists the liquidus 

temperature for the corresponding alloy composition. The liquidus temperatures for 

900 alloys are listed in the same report which allows a quick comparison of liquidus 

temperature for different alloy composition. User can also plot 3D colormap and 

surface diagrams using the data in this report as shown in Figure 1.23.8.  
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Figure 1.23.7: Analysis report file of TL 

 

Figure 1.23.8: 3D diagrams of the liquidus temperatures: colormap (left) and 3D 
surface (right) 
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Example 1.24 High Throughput Calculation (HTC): Random Compositions  

Purpose: Learn to perform HTC with random compositions. 

Module: PanPhasediagram 

Database: AlMgZn.tdb 

Calculation Method: HTC Calculations by Importing Alloy Compositions 

 Load AlMgZn.tdb 

 Start the HTC function from the menu “Batch Calc  High Throughput 

Calculaiton (HTC)”. Then choose “solidification” as calculation type. 

 Check the “Import Alloys” box at the solidification simulation popup window, 

and then click the “Import” button to import the pre-prepared alloy 

composition file (Example_#1.24_alloys.txt). 

 Click the “Run HTC” button perform HTC simulations 

 Save the workspace of the HTC results for further analysis as mentioned in 

Example 1.23. 

Figure 1.24.1: HTC solidification dialogs before (left) and after (right) import 

alloy composition file  

Please refer to the PandatTM 2020 manual Section 9 for detail information of preparing 

the alloy composition file. 
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Example 1.25 Friction-stir welding between AA5454 Al alloy and AZ91 Mg alloy 

Purpose: Learn to perform complicated multi-component vertical section calculations 

and understand the application of zero phase fraction (ZPF) line of the liquid phase. 

Commercial Mg database is required to perform the calculation of this example. 

Module: PanPhasediagram 

Database: PanMg2020.pdb 

Background: Due to the formation of brittle intermetallic phases in the fusion zone, 

joining Mg alloys with Al alloys through fusion welding is not very suitable. Friction 

stir welding (FSW) provides a potential method for joining Mg alloys and Al alloys. In 

this example, an AZ91 cast Mg alloy and rolled AA5454 Al alloy are assumed to be 

jointed through FSW. A vertical section from the composition of AZ91 to AA5454 

shows the possible intermetallic phases could be formed in the welding interface. In 

addition, the zero phase fraction line of the liquid phase indicates the maximum 

temperature that can be tolerated during the welding process to avoid the melting zone 

in the interface. 

Calculation Method: 

 Create a workspace and select the PanPhaseDiagram module following Pandat 

User’s Guide 2.1; 

 Load PanMg2020.pdb following the procedure in Pandat User’s Guide 3.2.1, 

and select the elements: Al, Fe, Mg, Mn, Zn.  

 Perform 2D calculation. (Also detailed described in Pandat User’s Guide 3.3.3) 

 Set Calculation Condition as shown in Figure 1.25.1; 

 As this is a complicated phase diagram calculation, option “extensive search” is 

recommended. Click options in the interface shown in Figure 1.25.1, an 

interface as shown in Figure 1.25.2 will pop-up. Select “Extensive Search” in 

the “PanEngine Settings”. Then click OK. (Detailed description on “Extensive 

Search” can be found in Pandat User’s Guide 3.2.2). Note that “extensive search” 

may not be necessary for most calculations, yet, it provides users with an 

option for the calculation of complicated diagrams. 
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Figure 1.25.1. Set vertical section calculation conditions: Composition from AA5454: 
Al-3Mg-1Mn-0.3Fe-0.01Zn(wt.%) at left edge to AZ91: Mg-8.2Al-1Zn-0.2Mn-0.01Fe 

(wt.%) at right edge; Temperature range from 300 °C to 500 °C. 

 

 
Figure 1.25.2: Set “Extensive Search” option. 
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 Set “Contour line” calculations to highlight the ZPF line of the liquid phase. 

Click “Contour line” in the interface shown Figure 1.25.1, The “Set Contour 

Lines” interface pop-up as shown in Figure 1.25.3, select the “f(@*)” from the 

Pre-Defined Contour Types, “f(@*)” means the fraction of certain phase, then 

select “Liquid” to replace the “*” to define the fraction of liquid phase. Start 

value and Stop value are set as “0”, and Step value set as “1”. Then click OK.  

 
Figure 1.25.3 Contour line setting for the ZPF line of the liquid phase.  

 The interface goes back to Figure 1.25.1, click OK to start calculation.  

Post Calculation Operation: 

 The default calculated phase diagram is shown as Figure 1.25.4. The left edge 

corresponds to the composition of AA5454 (Al-3Mg-1Mn-0.3Fe-0.01Zn(wt.%)), 

and the right edge is the composition of AZ91 (Mg-8.2Al-1Zn-0.2Mn-0.01Fe 

(wt.%)). The highlighted red line is the ZPF line of the liquid phase, which 

represents the melting temperature at each composition. In other words, liquid 

phase will appear above the red line.   

 Change the scale and increment of the diagram. (Also detailed described in 

Pandat User’s Guide 2.3.1) The scale of the axes can be set through the 

Property window at the left side of the interface as shown in Figure 1.25.5. In 

this example, X axis is set from 0 to 90.59, increment value 10. Y axis is set 

from 300 to 600 with increment of 50.  
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Figure 1.25.4 Default calculated phase diagram from AA5454 to AZ91.  

 

 
Figure 1.25.5 Graph property setting window to set axis scale, increment, title text.  
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 Label phase field (Also described in detail in Pandat User’s Guide 2.3.3); 

Click button  , Pandat goes into Label function, then click the mouse on the 

diagram, the phase field at the location of the mouse will be labeled. If the user 

holds the <Ctrl> key first and then click the mouse on the diagram, the 

program will do a point calculation at the composition and temperature where 

the cursor locates. After added all phase field labels and put them in proper 

position, the final phase diagram is shown as Figure 1.25.6.  

 
Figure 1.25.6 The vertical phase diagram from AA5454 to AZ91 with phase field labels. 

The phase fields including Liquid phase are labeled as red. 

Information obtained from this calculation: 

 The local temperatures in the welding zone during friction-stir welding process 

should be controlled to be lower than given by the red line to avoid partial 

melting. The lowest temperature in this case is 435.7 °C.  

 Different intermetallic phases may form in the joining zone: The Al3Mg2 phase 

with some Al6Mn precipitate near the Al alloy side, and Mg17Al12 phase with 

minor precipitation of Al4Mn near the Mg alloy side. 

 Similar approach can also be used to understand other reactions between 

different materials, for example coating/substrate reactions. 
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Example 1.26 Calculate Open Circle Voltage (OCV) under Equilibrium Condition  

Purpose: Learn to perform equilibrium calculation, use extra output table and extra 

output graph to output chemical potential and voltage value to simulate the open 

circle voltage curve of an alloy system for battery application.  

Module: PanPhasediagram 

Database: LiSn.tdb 

Background: Carbon based anode material is widely used in Li-ion batteries. But its 

low charge density motivates the search for next generation of anode materials. Sn 

based alloy is one of potential anode candidates. The calculation of open circle voltage 

curve of the Li-Sn system sheds a light on the potential capacity of the alloy system. 

This example shows how to calculate the open circle voltage curves directly from 

PanPhaseDigaram modular and compare with experimental data. In an alloy system, 

the equilibrium open-circle voltage E is associated with chemical potential through the 

Nernst equation: 
,o ref

Li Li nFE    . F is Faraday’s constant, 94685 C/volt. In this 

example of Li-Sn system, n = 1, then 
,( ) /o ref

Li LiE F    . At 688 K, Li and Sn are in 

liquid state, so the reference state is liquid Li.  

Calculation Method 1: 

 Create a workspace and select the PanPhaseDiagram module following Pandat 

User’s Guide 2.1; 

 From menu bar click Batch Calc-> Batch Run, select Example_#1.26.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPhaseDiagram module following Pandat 

User’s Guide 2.1; 

 Load LiSn.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Start line calculations, click PanPhaseDiagram -> Line Calculations or click the 

icon  from the toolbar. 

 A line calculation setting window will pop up as shown in Figure 1.26.1. The 

temperature is set as 688 K, as experimental data are available at 688 K for 

comparison. The composition range is from pure Sn, i.e. x(Sn) = 1, to pure Li, 

i.e. x(Li) = 1. The Number of steps is set to be 200. 
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Figure 1.26.1 Line calculation conditions setting. 

 Set “Extra Outputs table”. In order to output the open-circle voltage value, some 

extra outputs are required. Click “Extra Outputs” in the interface shown in 

Figure 1.26.1, a new interface will appear as shown in Figure 1.26.2. Then click 

the blue “+” symbol to pop out the Table Editor as shown in Figure 1.26.3. 

From this Table Editor, one can select to output Extra properties which are not 

shown in the default table.  

 
Figure 1.26.2 Interface to set Extra Output. 

 In this example, we output mu(Li:Liquid[Li]) as the chemical potential of Li in 

the system with reference to the liquid phase, i.e. 
,o Liquid

Li Li  . Then, we add 

another quantity -mu(Li:Liquid[Li])/96485 which is equivalent to 
,( ) /o Liquid

Li LiE F     in this system. The quantity x(Li)/x(Sn) represents the y 

in LiySn system. The settings are shown in Figure 1.26.3. After setting the table 

editor, click OK. 

 

Tips: The properties can be dragged from the left column to the right column, or 

directly type in the right column. When click a property in the left column, the 

description of this property is shown as description in the bottom of the 

interface. For example, in Figure 1.26.3, a(*:Liquid[*]); Description: Activity of 
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component in system with given reference state. Some simple calculations are 

also applied in the table setting, such as -mu(Li:Liquid[Li])/96485 and 

x(Li)/x(Sn) in this example.  

 
Figure 1.26.3 Define extra output table by drag properties from the left column to the 

right column or directly type in in the right column. 

 Set “Extra Outputs graph”. Click the icon “Graph” in “Set extra output” 

interface as shown in Figure 1.26.4, then click the blue “+” symbol to add extra 

Graph. An interface as shown in Figure 1.26.5 will appear. Select the 

“generated” table set in previous step in the “Table source”. Drag x(Li)/x(Sn) 

from the left column to X axis in the right column; drag -

mu(Li:Liquid[Li])/96485 from the left column to Y axis in the right column.  

Then click OK. 

 When the interface goes back to Figure 1.26.1, click OK. Calculation starts.  

 
Figure 1.26.4. Set Extra Output Graphs interface 
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Figure 1.26.5. Output Graphs option interface. 

Post Calculation Operation 

 Rescale the axis, and edit the axis title.  

After the calculation, the calculated open circle voltage curve of Li-Sn system is 

shown in Figure 1.26.6 with the default settings. Set the x-axis range from 0 to 

6, and obtained as shown in Figure 1.26.7. 

 
Figure 1.26.6 Calculated open circle voltage curve of Li-Sn system. 
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Figure 1.26.7 Calculated open circle voltage curve of Li-Sn system: Rescale x-axis of 

x(Li)/x(Sn) to 0-6. 

 Import experimental data. From the menu, click Table -> Import Table From 

Files, choose LiSn.txt file to import the experimental data table into the Pandat 

workspace.  

  

 Compare calculated results with experimental data. From the menu, click 

Graph -> Edit Plots, or click the button  from the toolbar to open the setup 

Plot interface as shown in Figure 1.26.8. Select the imported LiSn table, choose 

LixSn as X axis, and E_Li(V) as Y axis. Then click OK. 

 

 

 
Figure 1.26.8 Setup Plot, add the experimental data into generated figure. 
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Then change “Plot Type” as “Point”, “Marker Color” as “Transparent”, “Marker Style” as 

“Circle”; Then experimental data are changed to red open symbol, added legend, 

change the Title of Y axis as (E vs ELi ) / V. The final produced figure is shown in 

Figure 1.26.9.  

 
Figure 1.26.9 The calculated OCV curve of Li-Sn system at 688 K in comparison with 

experimental data. 
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2 PanOptimizer 

Example 2.1 Parameter Optimization for the Fe-Cr-Ni Ternary System 

Purpose: Learn to optimize thermodynamic parameters for a ternary system 

Module: PanOptimizer 

Database: Fe-Cr-Ni_OPT.tdb & Fe-Cr-Ni_OPT.pop 

Figure 2.1.1 shows an experimentally determined isothermal section of the Fe-Cr-Ni 

ternary system at 900oC. Two solution phases, Bcc (α) and Fcc (γ), and one 

intermetallic compound (σ) are stable at this temperature. The experimental data 

includes tie-lines (equilibrium between two different phases) and tie-triangles 

(equilibrium of three different phases). This example shows how to optimize the 

thermodynamic parameters for this system using the given experimental data. 

 
Figure 2.1.1： Experimentally determined Fe-Cr-Ni isothermal section at 900oC  

Prepare files:  

 Prepare the database file and pop following the procedure in Pandat User’s 

Guide 4.3.1; 

The binary thermodynamic parameters are selected from literature, which are 

proven to describe the corresponding binary systems precisely. And the ternary 

interaction parameters are set for optimization. User may go through the 

database file (Fe-Cr-Ni_OPT.tdb) for more details. 

The experimental data are input into the pop file (Fe-Cr-Ni_OPT.pop). The tie-

lines are stored in table format by giving an overall alloy composition at the 



PandatTM 2020 Example Book 

~ 89 ~ 
 

midpoint of the each tie-line. The tie-triangles are input by giving an overall 

alloy composition at centre point of each triangle. In both cases, the phases use 

"ENTER" status so that PanOptimizer can easily find the corresponding 

equilibrium.  

Perform Optimization:  

 Load the database  and experimental files (tdb and pop files) following the 

procedure in Pandat User’s Guide 4.3.2; 

User may check the parameters to be optimized by clicking the "Parameters" button on 

the optimization control panel, and check the difference between calculated 

equilibrium and experiments by clicking the "Experimental Data" button as shown in 

the red box in Figure 2.1.2.  

 
Figure 2.1.2: Optimization result after one round  

After several runs of optimization, the sum of squares will reach a minimum and does 

not change, which means PanOptimizer has found an optimal result for the 

parameters. User may calculate an isothermal section at 900oC and compare to the 

experimental data. As shown in Figure 2.1.3, the calculated phase boundaries are in 

good agreement with the experimental data. And user may also need to check the 

values of the parameters and make sure that they are reasonable as shown in Figure 

2.1.4. If there is noticeable difference between calculated boundary and the 

experimental data, user need to figure out new ternary parameters that need to be 

included in optimization or using more complicated model to describe the 

corresponding phases. 
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Figure 2.1.3: Comparison between calculated isothermal section at 900oC and 

experimental data 

 

 
Figure 2.1.4: Optimization results 
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3 PanPrecipitation 

Example 3.1 Precipitation Simulation of Ni-14Al (at%) Alloy   

Purpose: Learn to perform a precipitation simulation of a binary alloy. In this example, 

precipitation simulation will be performed for Ni-14Al alloy during isothermal ageing at 

550oC, and experimental data will be added to the plots; 

Module: PanPrecipitation 

Database: AlNi_Prep.tdb and Ni-14Al_Precipitation.kdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#3.1.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPrecipitation module following Pandat 

User’s Guide 2.1; 

 Load AlNi_Prep.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on PanPrecipitation on the menu bar and select Load KDB, then select the 

Ni-14Al_Precipitation.kdb, a dialog will pop out as shown in Figure 3.1.1. This 

dialog shows the key information stored in the Ni-14Al_Precipitation.kdb, i.e, 

the matrix phase is Fcc, and the precipitate phase is L12_FCC; 

 Click File->Open File to open the Ni-14Al_Precipitation.kdb. As shown in Figure 

3.1.2, in addition to the matrix phase and precipitate phase, other parameters, 

such as, molar volume and interfacial energy are also defined in this file. 

Details on these parameters can be found in Pandat User’s Guide 5.1.4; 

 Click on PanPrecipitation on the menu bar and click Precipitation Simulation. A 

dialog will pop out as shown in Figure 3.1.3, set up the alloy chemistry on the 

left and the heat treatment condition on the right. In this setting, an isothermal 

ageing is performed at 550oC assuming the initial state is pure Fcc phase; 

 
Figure 3.1.1: Loading the Ni-14Al_Precipitation.kdb 
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Figure 3.1.2: Parameters defined in the Ni-14Al_Precipitation.kdb 

 

 
Figure 3.1.3: Setup the alloy chemistry (Ni-14 at%Al) and heat treatment condition 

(isothermal ageing at 550oC) for the simulation 
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Post Calculation Operation: 

 Right click the Default graph and rename it as Vf; 

 Create a new table as shown in Figure 3.1.4. A new table with two columns will 

be created with the first time in hour and the second size of L12_FCC in 

nanometer. Create a plot from this table and rename it as Size; 

 Create a new table as shown in Figure 3.1.5. A new table with two columns will 

be created with the first log(time in minute) and the second the number density 

of L12_FCC in cm3. Create a plot from this table and rename it as nd; 

 Import a table from a file as shown in Figure 3.1.6, and select Ni-14Al_Exp.dat; 

 Open the Size graph, single click the Ni-14Al_Exp table and drag in the t(hr) as 

x-axis, press Ctrl and drag in the radius(nm) as y-axis. In the Property window 

set the Plot Type as Point, the plot with experimental data point is shown in 

Figure 3.1.7; 

 Open the nd graph and add the experimental data on it as shown in Figure 

3.1.8; 

 Create a new table as shown in Figure 3.1.9, select psd as the Table Type; 

select the psd_s(L12_FCC) and the psd_nnd(L12_FCC) two columns to create a 

new plot as shown in Figure 3.1.10; 

 
Figure 3.1.4: Create a new table with two columns with the first column time (hour) 

and the second column the precipitate size (nm) 

 
Figure 3.1.5: Create a new table with two columns with the first column log(time) and 

the second the number density of the precipitate per cm^3 
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Figure 3.1.6: Import an experimental data table from a file 

 

 
Figure 3.1.7: Plot of size evolution with experimental data 
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Figure 3.1.8: Plot of number density evolution with experimental data 

 

 
Figure 3.1.9: Create a new table for particle size distribution 
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Figure 3.1.10: Plot of particle size distribution 

Information obtained from this calculation: 

 It is common practice to plot the experimental data on the calculated diagram. 

When doing so, it is important to make unit consistency between the 

experimental data and the calculated property. In Pandat calculation, 

international standard unit is used, i.e., second for time, meter for length and 

cube meter for volume, and so on; 

 Particle number density counts the number of particles in a unit volume. 

Default output from Pandat is number per m3, it was converted to number per 

cm3 in Figure 3.1.8; 

 The psd_nnd(L12_FCC) in Figure 3.1.10 is normalized number density, which 

equals to the particle numbers of each size class divided by the total particle 

numbers; 

 Figure 3.1.10 shows four distribution curves at four different times. The sharp 

one is at early nucleation stage which shows small particle size and high 

number density, the flat one shows the particle size distribution as final time 

(100 hours in this simulation). The corresponding time of each distribution can 

be found in the table. When create the table, simply put this time information 

in the table as shown in Figure 3.1.11; 

 To only plot the particle size distribution curve at one time, set the index=1, or 

2...or i. index=i means the final distribution. Figure 3.1.12 shows the table 

created for the final size distribution and Figure 3.1.13 shows the distribution 

curve; 
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Figure 3.1.11: List the index and corresponding time for each size distribution curve 

 
Figure 3.1.12: Create the table for final size distribution 

 
Figure 3.1.13: Plot for final size distribution and the plot 
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Example 3.2 TTT diagram of Ni-14Al (at%) Alloy   

Purpose: Learn to calculate the TTT curve for a given alloy; 

Module: PanPrecipitation 

Database: AlNi_Prep.tdb and Ni-14Al_Precipitation.kdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#3.2.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPrecipitation module following Pandat 

User’s Guide 2.1; 

 Load AlNi_Prep.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on PanPrecipitation on the menu bar and select Load KDB, then select the 

Ni-14Al_Precipitation.kdb; 

 Click on PanPrecipitation on the menu bar and select TTT Simulation, a dialog 

will pop out as shown in Figure 3.2.1. In this dialog, user needs to input the 

alloy chemistry (left), temperature range and step (bottom right) and the Target 

volume fraction (top right). If the “Relative Vol%” box is checked, it means the 

Target Vol% is relative to the equilibrium fraction of the precipitate phase at 

each temperature, otherwise it is the volume fraction of the precipitate phase; 

 

 
Figure 3.2.1: Setup a calculation of TTT curve for Ni-14Al (at%) 
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Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add text following the procedure in Pandat User’s Guide 2.3.3; 

Information obtained from this calculation: 

 Figure 3.2.2 shows the default plot from the calculation. It should point out 

that this TTT curve represents the time-Temperature curve when 2% of the 

equilibrium precipitate at each temperature comes out. For example, the 

equilibrium fraction of L12_FCC precipitate phase is 16.56% at 650oC, 2% of it 

is 0.33%. In other words, it takes 6.6 second to precipitate 0.33% of L12_FCC at 

this temperature. 

 Perform another calculation for 10% and merge the two plots as shown in 

Figure 3.2.3; 

 Details on the time, temperature and fraction of precipitate can be found in the 

Default table; 

 
Figure 3.2.2: TTT curve for Ni-14Al (at%) when 2% of equilibrium L12_FCC formed 
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Figure 3.2.3: Comparison of TTT curves for Ni-14Al (at%) when 2% or 10% of 

equilibrium L12_FCC formed 
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Example 3.3  Co-precipitation of γ and γ in the Ni-Al-Nb Pseudo-ternary System  

Purpose: Learn to calculate co-precipitation of  and  for an alloy in a pseudo-

ternary system; 

Module: PanPrecipitation 

Database: NiAlNb_Pseudo.tdb and Ni-2.4Al-3.8Nb.kdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#3.3.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPrecipitation module following Pandat 

User’s Guide 2.1; 

 Load NiAlNb_Pseudo.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on PanPrecipitation on the menu bar and select Load KDB, then select the 

Ni-2.4Al-3.8Nb.kdb, the pop-out window is shown in Figure 3.3.1 which include 

the alloy name, the matrix phase and the precipitates. Two precipitates are 

defined in this case; 

 Open the Ni-2.4Al-3.8Nb.kdb from Pandat workspace through File->Open File, 

and view the kinetic parameters as shown in Figure 3.3.2; 

 Click on PanPrecipitation->Precipitation Simulation, and set up the calculation 

condition as shown in Figure 3.3.3; 

 
Figure 3.3.1: Pop-out window when loading the Ni-2.4Al-3.8Nb.kdb 
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Figure 3.3.2: Open the Ni-2.4Al-3.8Nb.kdb in Pandat workspace to view the kinetic 

parameters of the two precipitate phases 

 

Figure 3.3.3: Precipitation simulation of alloy Ni-2.4Al-3.8Nb ageing at 790oC for 10h 
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Post Calculation Operation: 

 The default plot shows the total volume fraction of  and  as a function of 

time; 

 Open the Default Table, create time vs. volume fractions of  and , and time 

vs. sizes of  and  plots as shown in Figure 3.3.4 and Figure 3.3.5; 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add legend following the procedure in Pandat User’s Guide 2.3.3; 

 

 
Figure 3.3.4: Calculated volume fraction evolution of the two precipitate phases 
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Figure 3.3.5: Calculated average size evolution of the two precipitate phases 

 

Information obtained from this calculation: 

 Figure 3.3.4 shows the calculated evolution of volume fraction of the two 

precipitate phases. It is seen that  precipitated quickly at very early stage, but 

gave way to  at later time; 

 Figure 3.3.5 shows the calculated evolution of the average size of the two 

precipitate phases. It is seen that  is bigger than ; 

 Add a new table as shown in Figure 3.3.6 with the Table Type as psd. The 

Columns are particle sizes and number densities with (@*) means all precipitate 

phases. The default calculated size is in meter, which is converted to nm by 

multiplying the column by 1e+9. The default calculated number density is 

number/m^3, which is converted to mol/m^3. The index=i means to populate 

the size and number density at the final state t=10h; 

 Plot particle size distribution from the new table by selecting the particle size as 

x-axis and number density as y-axis. Plot it for L12 () phase first and then add 

the one for  as shown in Figure 3.3.7; 
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Figure 3.3.6: Create a new table with particle sizes and number densities at final stage 

 

 

Figure 3.3.7: Particle size distributions of  and  at final stage  
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Example 3.4 Simulation of Hardness of Aluminum Alloy 6005  

Purpose: Learn to calculate the particle size, number density and hardness of 

aluminum alloy 6005; 

Module: PanPrecipitation 

Database: AlMgSi.tdb and AA6xxx.kdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#3.4.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPrecipitation module following Pandat 

User’s Guide 2.1; 

 Load AlMgSi.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on PanPrecipitation on the menu bar and select Load KDB, then select the 

AA6xxx.kdb, the pop-out window is shown in Figure 3.4.1 which include the 

alloy name, the matrix phase and the precipitate phase; 

 Open the AA6xxx.kdb from Pandat workspace through File->Open File, and 

view the kinetic parameters; 

 Click on PanPrecipitation->Precipitation Simulation, and set up the calculation 

condition as shown in Figure 3.4.2. Note the alloy composition is wt% (click 

Option button to select the unit); 

 
Figure 3.4.1: The matrix phase and the precipitate phase for AA6005 
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Figure 3.4.2: Setup alloy chemistry and heat treatment condition 

 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add legend following the procedure in Pandat User’s Guide 2.3.3;  

 Create a new table as shown in Figure 3.4.3, and plot the log(t) vs. log(nd), log(t) 

vs. log(size), and log(t) vs. hv; 

 Click Table below the Graph and choose Input Table from File, input three 

tables: AA6005-nd_exp.dat, AA6005-size_exp.dat, and AA6005-hv_exp.dat one 

by one; 

 Plot the experimental data in the corresponding plot by drag in the x-axis and 

then press Ctrl and drag in the y-axis of the experimental data table; 

 The default plot of the experimental data is a line instead of points. In the 

Property Window, change the Plot Type as Point; 
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Figure 3.4.3: Create a new table 

Information obtained from this calculation: 

 Figure 3.4.4 shows the default plot of the simulation which is volume fraction 

evolution of the precipitate phase. The time is in second; 

 Figure 3.4.5 shows the calculated number density evolution; Figure 3.4.6 

shows the size evolution, and Figure 3.4.7 the hardness change with time. 

Experimental data are plotted on them for comparison; 

 It is seen that the number density reaches the highest value at ~1000s (~0.3h), 

but the particle size is very small. The hardness reaches peak at ~10000s 

(~2.8h) when both the number density and the particle size are favorable; 

 
Figure 3.4.4: Default plot of volume fraction evolution of the precipitate 
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Figure 3.4.5: Evolution of the particle number density with experimental data 

 

 
Figure 3.4.6: Evolution of the particle size with experimental data 
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Figure 3.4.7: Evolution of hardness with experimental data 
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Example 3.5 Simulation of Softening of Aluminum Alloy 6005  

Purpose: Learn to calculate the particle size, number density and hardness of 

aluminum alloy 6005 during ageing and reheating; 

Module: PanPrecipitation 

Database: AlMgSi.tdb and AA6xxx.kdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#3.5.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPrecipitation module following Pandat 

User’s Guide 2.1; 

 Load Al-Mg-Si.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on PanPrecipitation on the menu bar and select Load KDB, then select the 

AA6xxx.kdb; 

 Click on PanPrecipitation->Precipitation Simulation, and set up the calculation 

condition as shown in Figure 3.5.1; 

 

 
Figure 3.5.1: Setup heat treatment condition as ageing at 185oC for four hours and 

then quickly heat up to 350oC and hold for 1 hour  
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Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add legend following the procedure in Pandat User’s Guide 2.3.3;  

 Create a new table as shown in Figure 3.5.2, and plot the t vs. log(nd), t vs. 

log(size), and t vs. hv; 

 Click Table below the Graph and choose Input Table from File, input table: 

AA6005-reheat_exp.dat; 

 Plot the experimental data in the corresponding plot by drag in the x-axis and 

then press Ctrl and drag in the y-axis of the experimental data table; 

 

 
Figure 3.5.2: Create a new table 

 

Information obtained from this calculation: 

 Figure 3.5.3 shows the calculated evolution of particle number density with 

experimental data, time is in second. It is seen that the particle number density 

increases quickly within the first hour and then decreases slightly during 

ageing at 185oC. It decreases drastically when heating up to 350oC; 

 Figure 3.5.4 shows the calculated evolution of particle size with experimental 

data. It is seen that the particle size increases gradually during ageing at 185oC. 

It increases drastically when heating up to 350oC; 

 Figure 3.5.5 shows the calculated evolution of hardness with experimental data. 

It is seen that the hardness increases gradually during ageing at 185oC. It drops 

quickly when heating up to 350oC; 
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Figure 3.5.3: Calculated evolution of particle number density with experimental data 

 

 
Figure 3.5.4: Calculated evolution of particle size with experimental data 
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Figure 3.5.5: Calculated evolution of hardness with experimental data 
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Example 3.6 Simulation of Yield Strength of Aluminum Alloy 357  

Purpose: Learn to calculate yield strength including intrinsic, solid solution, and 

precipitation strengthening of aluminum alloy 356 during the process of ageing; 

Module: PanPrecipitation 

Database: AlMgSi.tdb and AA3xx.kdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#3.6.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanPrecipitation module following Pandat 

User’s Guide 2.1; 

 Load AlMgSi.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on PanPrecipitation on the menu bar and select Load KDB, then select the 

AA3xx.kdb; 

 Click on PanPrecipitation->Precipitation Simulation, and set up the calculation 

condition as shown in Figure 3.6.1. Note that the “Equilibrium Calculation” 

button under Initial Structure (bottom) should be checked and the solution 

temperature (540oC in this case) should be given; 

 

 
Figure 3.6.1: Setup calculation condition for aluminum alloy 356 



PandatTM 2020 Example Book 

~ 116 ~ 
 

Post Calculation Operation: 

 Change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add legend following the procedure in Pandat User’s Guide 2.3.3;  

 Create a new table as shown in Figure 3.6.2, and select all the columns in the 

newly created table to create a plot; 

 Click Table below the Graph and choose Input Table from File, input table: 

AA356-ys_exp.txt; Note that the extension of a data file can be either txt or dat; 

 Plot the experimental data in the corresponding plot by drag in the x-axis and 

then press Ctrl and drag in the y-axis of the experimental data table; 

 

 
Figure 3.6.2: Create a new table for yield strength plot 
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Figure 3.6.3: A comparison of the calculated yield strength (lines) with the 
experimental data (symbols) 

 

Information obtained from this calculation: 

 Figure 3.6.3 shows a comparison of the calculated yield strength (lines) with the 

experimental data (symbols). The green line (symbol) represents the intrinsic 

contribution; the black line (symbol) represents the solid solution strengthening; 

the red line (symbol) represents the precipitation strengthening; and the blue 

line (symbol) is the total from all three contributions; 

 Create a new table as shown in Figure 3.6.4, select log10(time/3600) as x-axis, 

and x%(Mg@_Fcc) and x%(Si@_Fcc) as y-axis to create a plot as shown in Figure 

3.6.5; 

 It is clearly seen from Figure 3.6.3 and Figure 3.6.5 that with the formation of 

Mg5Si6 precipitate, the solubility of Mg and Si in Fcc decreases and solution 

strengthening also decreases; 
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Figure 3.6.4: Create a new table to show the evolution of phase compositions 

 

 
Figure 3.6.5: Evolution of elemental solubility in the matrix Fcc 
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4 PanDiffusion 

Example 4.1 Diffusion within a Single Phase: Uniform Composition on Each Side  

Purpose: Learn to perform diffusion simulation at constant temperature for a diffusion 

couple with both sides having the same single phase structure and uniform 

composition through each side before diffusion; 

Module: PanDiffusion 

Database: FeCrNi.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.1.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load FeCrNi.tdb following the procedure in Pandat User’s Guide 3.2.1 and 

select all three elements;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.1.1. First select Region Composition 

Distribution as Uniform, which means that composition in each region is 

uniform before diffusion. Click on Region_1 and set the composition of the left 

side of the diffusion couple as 30Cr-10Fe-60Ni (at%), then click on Region_2 

and set the composition of the right side of the diffusion couple as 10Cr-20Fe-

70Ni (at%) (which is not shown in Figure 4.1.1).  

 The length of both Region_1 and Region_2 is set to be 100 um, and the total 

number of grids (# of Grids) is 100. 

 The Thermal History is holding the diffusion couple at 1000oC for 1000 hours.  

 The default output includes composition profiles of the initial and final stages. 

Composition profiles can also be plotted and listed in the table for intermediate 

times. By clicking the blue “+” next to the “Moments for Profile Outputs” 

composition profiles for number of intermediate stages can be outputted. As 

shown in Figure 4.1.1, those at 200 hour and 500 hour will be outputted. Click 

OK to start calculation. 

 User can define the Geometry as Planar, Cylindrical, and Spherical; 

 User can also select the Effective Mobility Model and Interface Flux Model. 

Details on these options can be found in Pandat User’s Guide sections 6.6.11 

and 6.6.12. 
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Figure 4.1.1: Setting of the simulation condition 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.1.2. Add text and change graph 

appearance following the procedure in Pandat User’s Guide 2.3.1; 

 In addition to Default table, composition profiles at selected times are given in 

separated tables under Table, which can be plotted separately as shown in 

Figure 4.1.3.  

Information obtained from this calculation: 

 In this example, the initial compositions of the two regions of the diffusion 

couple are both in the single Fcc phase field as shown in the isotherm of Fe-Cr-

Ni at 1000oC in Figure 4.1.4; 

 Composition profiles at selected times can be obtained; 
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Figure 4.1.2: Calculated composition profiles after diffusion for 200, 500 and 1000 

hours, respectively 

 

 
Figure 4.1.3: Calculated composition profiles after diffusion for 200 hours 



PandatTM 2020 Example Book 

~ 122 ~ 
 

 

Figure 4.1.4: Isothermal section of Ni-Cr-Fe at 1000oC, the initial compositions of both 
sides locate in the single Fcc phase field 
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Example 4.2 Diffusion within a Single Phase: Linear Composition on Each Side  

Purpose: Learn to perform diffusion simulation at constant temperature for a diffusion 

couple with both sides having the same single phase structure and composition varies 

linearly through each side before diffusion; 

Module: PanDiffusion 

Database: FeCrNi.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.2.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load FeCrNi.tdb following the procedure in Pandat User’s Guide 3.2.1 and 

select all three elements;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.2.1. First select Region Composition 

Distribution as “Linear”, which means the composition in each region varies 

linearly from the left edge to the right edge. Click on Region_1 and set the 

composition of the left edge as 30Cr-10Fe-60Ni (at%), and that of the right edge 

as 10Cr-20Fe-70Ni (at%); then click on Region_2 and set the composition of the 

left edge as 10Cr-20Fe-70Ni (at%), and that of the right edge as 30Cr-10Fe-60Ni 

(at%) (not shown in Figure 4.2.1).  

 The length of both Region_1 and Region_2 is set to be 100 um, and the total 

number of grids (# of Grid) is 100. 

 The Thermal History is holding the diffusion couple at 1000oC for 1000 hours.  

 The output composition profiles include the initial and final stages and one 

intermediate stage at 100 hours. Click OK. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.2.2. Add text and change graph 

appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 Composition shows linear distribution in both regions at the beginning; 

 After holding the diffusion couple at 1000oC for 1000 hours, the diffusion 

couple becomes nearly homogenized; 
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Figure 4.2.1：Setting of the simulation condition 

 

 
Figure 4.2.2: Calculated composition profiles at 100 hour and 1000 hour 
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Example 4.3 Diffusion between Two Phases: Uniform Composition on Each Side  

Purpose: Learn to perform diffusion simulation at constant temperature for a diffusion 

couple with the two sides having different phase structure and uniform composition 

through each side before diffusion; 

Module: PanDiffusion 

Database: FeCrNi.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.3.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load FeCrNi.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.3.1. First select Region Composition 

Distribution as Uniform. Click on Region_1 and set the composition of the left 

region of the diffusion couple as 30Cr-10Fe-60Ni (at%), then click on Region_2 

and set the composition of the right region of the diffusion couple as 55Cr-

40Fe-5Ni (at%).  

 The length of both Region_1 and Region_2 is set to be 100 um, and the number 

of grids of both Region_1 and Region_2 is set to be 50. 

 The Thermal History is holding the diffusion couple at 1000oC for 200 hours.  

 In the setting shown in Figure 4.3.1, composition profiles only at the initial and 

final stages will be outputted. Click OK to perform calculations. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.3.2. Add text and change graph 

appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 The two sides of the diffusion couple locate at different phase fields, one in Fcc 

and the other in Bcc as shown in the isotherm of Fr-Cr-Ni at 1000oC in Figure 

4.3.3, therefore diffusion between them pass through the Fcc+Bcc two-phase 

field; 

 After holding the diffusion couple at 1000oC for 200 hours, boundary between 

the Fcc and Bcc moved; 
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Figure 4.3.1: Setting of the simulation condition 

 

 
Figure 4.3.2: Calculated composition profiles after diffusion at 1000oC for 200 hours  
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Figure 4.3.3: Isothermal section of Ni-Cr-Fe at 1000oC, the initial compositions of the 

two sides locate in different phase fields, one in Fcc and the other in Bcc 
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Example 4.4 Diffusion between Two Phases at Varied Temperature: Uniform 

Composition on Each Side  

Purpose: Learn to perform diffusion simulation at varied temperatures for a diffusion 

couple with the two sides having different phase structure and uniform composition 

through each side before diffusion; 

Module: PanDiffusion 

Database: FeCrNi.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.4.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load FeCrNi.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.4.1. First select Region Composition 

Distribution as Uniform. Click on Region_1 and set the composition of the left 

region of the diffusion couple as 30Cr-10Fe-60Ni (at%), then click on Region_2 

and set the composition of the right region of the diffusion couple as 55Cr-

40Fe-5Ni (at%).  

 The length of both Region_1 and Region_2 is set to be 100 um, and the number 

of grids of both Region_1 and Region_2 is set to be 50. 

 The Thermal History is holding the diffusion couple at 1000oC for 200 hours, 

then the temperature decreases from 1000oC to 900oC linearly in the next 100 

hours.  

 Click “Select Phase” and set Fcc and Bcc as the entered phases. 

 In the setting shown in Figure 4.4.1, composition profiles at only the initial and 

final stages will be outputted. Click OK to perform calculations. 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.4.2; 

 Add text and change graph appearance following the procedure in Pandat 

User’s Guide 2.3.1; 

Information obtained from this calculation: 

 After holding the diffusion couple at 1000oC for 200 hours, the temperature 

decreases gradually in the next 100 hours to 900oC. Composition profiles after 

the entire thermal history can be obtained; 

 Learn to set up multi-step thermal history for a diffusion simulation;  
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Figure 4.4.1: Setting the simulation condition 

 
Figure 4.4.2: Calculated composition profiles at 300 hours  
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Example 4.5 Diffusion among Multiple Regions  

Purpose: Learn to perform diffusion simulation at constant temperature for a diffusion 

sandwich with different phase structure but uniform composition through each region 

before diffusion; 

Module: PanDiffusion 

Database: FeCrNi.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.5.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load FeCrNi.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.5.1. First click the blue “+” above Regions to add 

another region, Region_3. Select Region Composition Distribution as “Uniform”. 

 Click on Region_1 and set the composition of the left region of the diffusion 

triple as 30Cr-10Fe-60Ni (at%). Select Fcc as the entered phase in “Select 

Phases” of “Settings for the Selected Region [Region_1]”.  

 Click on Region_2 and set the composition of the middle region of the diffusion 

triple as 55Cr-40Fe-5Ni (at%), Select Bcc as the entered phase in “Select Phases” 

of “Settings for the Selected Region [Region_2]”. 

 Click on Region_3 and set the composition of the right region of the diffusion 

triple as 10Cr-20Fe-70Ni (at%). Select Fcc as the entered phase in “Select 

Phases” of “Settings for the Selected Region [Region_3]”. 

 The length of each region is set to be 100 um, and the number of grids (# of 

Grids) is the default value of 100. 

 The Thermal History is holding the diffusion sandwich at 1000oC for 500 hours.  

 In the setting shown in Figure 36.1, composition profiles at the initial and final 

stages, as well as that at 200 hour will be outputted. Click OK to perform 

calculations. 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.5.2. Add text and change graph 

appearance following the procedure in Pandat User’s Guide 2.3.1; 
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Information obtained from this calculation: 

 The three regions of the diffusion triple locate at different phase fields, the one 

in Bcc is sandwiched between two regions in the Fcc as shown in Figure 4.5.3; 

 After holding the diffusion couple at 1000oC for 500 hours, composition profiles 

can be viewed at final stage (500h) and intermediate stage (200h). The phase 

boundaries are moved; 

 

 
Figure 4.5.1: Setting of the simulation condition 
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Figure 4.5.2: Calculated composition profiles for the diffusion sandwich at 1000oC for 

200h and 500h  

 
Figure 4.5.3: Isothermal section of Ni-Cr-Fe at 1000oC, the initial compositions of the 

left and right regions locate in the single Fcc phase field, while the middle region 
locates in the Bcc phase field  
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Example 4.6 Carburization with Fixed Composition at Boundary  

Purpose: Learn to perform diffusion simulation at constant temperature for a 

carburization process with a fixed chemical composition at boundary.  

Module: PanDiffusion 

Database: Fe-Si-C.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.6.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load Fe-Si-C.tdb, and select component Fe can C, following the procedure in 

Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.6.1. First click the red “X” above the Regions 

setting to delete Region_2 and leave one Region only. Click on Region_1, set the 

composition as 0.5C-99.5Fe (at%), the Diff. Length as 100 um, and the # of 

Grids as 100. 

 The Thermal History is set as 1200 K for 25 seconds; 

 Click on Lower Boundary Condition (left edge of Region_1) and select 

“fixed_composition”, and set the Value as “x%(C)=3.0”; 

 In the setting shown in Figure 4.6.1, composition profiles at the initial and final 

stages will be outputted. Click OK to perform calculations. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.6.2. Enlarge the composition range 

between 0 and 4 (at%) to clearly display Carbon composition. Add text and 

change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 Carbonization process in Fcc phase in the Fe-C system. Lower boundary 

condition is a fixed carbon composition; 

 After holding the material at 1200K for 25 seconds, composition profiles can be 

viewed at final stage (25 s). The carbon gradually diffused into the Fcc phase 

from the boundary; 
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Figure 4.6.1: Setting of the simulation condition 

 
Figure 4.6.2: Calculated C composition profile for diffusion at 1200K for 25s  
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Example 4.7 Carburization with Input Flux 

Purpose: Learn to perform diffusion simulation at constant temperature for a 

carburization process with an input flux as boundary condition.  

Module: PanDiffusion 

Database: Fe-Si-C.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.7.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load Fe-Si-C.tdb, and select component Fe can C, following the procedure in 

Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.7.1. First click the red “X” above Regions setting 

to delete  Region_2. Click on Region_1, set the composition as 0.15C-99.85Fe 

(wt%), the Diff. Length as 3 mm, and the # of Grids as 200. 

 The Thermal History is at 1173 K for 18000 seconds; 

 Click on Lower Boundary Condition (left edge of Region_1) and select “flux”, and 

set the Value as “J(C)=-8.25E-9*(a(C:Graphite[*])-0.64)/7e-006”; 

 In the setting shown in Figure 4.7.1, composition profiles at the initial and final 

stages, as well as at 100s, 1000s and 5000s, will be outputted. Click OK to 

perform calculations. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.7.2. Enlarge the composition range 

between 0 and 1 (wt%) to clearly display Carbon composition. Add text and 

change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 Carbonization process in Fcc of the Fe-C system. Lower boundary condition is 

an input flux. This setting provides user an option when the flux of C is known 

in the environment; 

 After holding the material at 1173K for 18000 seconds, composition profiles can 

be viewed at selected stages. The carbon composition gradually diffused from 

the boundary to the body; 
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Figure 4.7.1: Setting of the simulation condition 

 

 
Figure 4.7.2: Calculated C composition profiles for diffusion at 1173 K for 100s, 1000s, 

5000s, and 18000s 
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Example 4.8 Carburization of a Tube with Fixed Environmental Activity 

Purpose: Learn to perform diffusion simulation at constant temperature for a 

carburization process of tube material with fixed environmental activities on both 

inner and outer surfaces.  

Module: PanDiffusion 

Database: Fe-Si-C.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.8.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load Fe-Si-C.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.8.1. First click the red “X” above Regions setting 

to delete Region_2. Click on Region_1, set the composition as 0.05C-98.65Fe-

1.3Si (wt%), the Diff. Length as 10 mm, and the # of Grids as 100. 

 Click “Select Phase” and set Fcc as the entered phase. 

 The Thermal History is at 1273 K for 2E5 seconds; 

 Click on Upper Boundary Condition and select “activity”, then set the activity 

value at the right edge of Region_1 as “a(C:graphite[*])=1E-5”. Click on Lower 

Boundary Condition and select “activity”, then set the activity value at the left 

edge of Region_1 as “a(C:graphite[*])=0.9”; 

 In order to set a tube geometry, select “cylindrical” in “Geometry”, and apply 20 

mm to “Inner Radius” 

 In the setting shown in Figure 4.8.1, composition profiles at the initial and final 

stages, as well as at 1E4 s, will be outputted. Click OK to perform calculations. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.8.2. Enlarge the composition range 

between 0 and 1.4 (wt%) to clearly display Carbon composition. Add text and 

change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 Learn to set up Boundary conditions for a tube geometry, and fixed activities at 

both inner and outer surfaces; 

 Observe carbon diffusion from inner surface (high activity) into the tube; 
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Figure 4.8.1: Setting of the simulation condition 

 
Figure 4.8.2: Calculated composition profiles at 1273 K for 1E4s, and 2E5s  
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Example 4.9 Dissolution of 𝜸′ Particle in 𝜸 Matrix 

Purpose: Learn to perform diffusion simulation at constant temperature where a  γ′ 

particle (L12, Ni3Al) dissolve into γ matrix (Fcc, Ni-Al). Learn to select entered phase(s) 

in each region. 

Module: PanDiffusion 

Database: AlNi_Diff.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.9.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load AlNi_Prep.tdb following the procedure in Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.9.1. Click on Region_1 and set the composition 

as 25Al-75Ni (at%) and select L12_FCC as the entered phase in “Select Phases” 

of “Settings for the Selected Region [Region_1]”. In Region_1, set the Diff. Length 

as 5 um. Click on Region_2 and set the composition as 15Al-85Ni (at%) and 

select Fcc as the entered phase in “Select Phases” of “Settings for the Selected 

Region [Region_2]”. In Region_2, set the Diff. Length as 10 um. 

 The Thermal History is at 1473 K for 100 seconds; 

 Select “spherical” in “Geometry”.  The total number of grids (# of Grids) is 100. 

 In the setting shown in Figure 4.9.1, composition profiles at the initial and final 

stages, as well as at 10s, 30s, 50s and 70s, will be outputted. Click OK to 

perform calculations. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.9.2. Add text and change graph 

appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 Learn to set up simulation for dissolution of spherical particles. 

 After holding the material at 1473K for 100s, composition profiles can be viewed 

at selected stages. The interface moving from 𝛾  phase to 𝛾′  indicates the 

dissolution of 𝛾′ particles. 
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Figure 4.9.1: Setting of the simulation condition 

 

 
Figure 4.9.2: Calculated composition profiles at 1473 K for 10s, 30s, 50s, 70s and 

100s. 
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Figure 40.3: Ni-Al phase diagram. The initial composition of left-hand side locates in 

the single L12-FCC phase field. The initial composition of right-hand side locates in 

the single Fcc phase field. 
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Example 4.10 Transformation from 𝜸 to 𝜶  

Purpose: Learn to perform diffusion simulation at constant temperature where a γ-> α 

transformation happens in Fe-C alloy. Learn to select entered phase(s) in each region. 

Module: PanDiffusion 

Database: Fe-Si-C.tdb 

Calculation Method 1:  

 From menu bar click Batch Calc-> Batch Run, select Example_#4.10.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load Fe-Si-C.tdb, and select component Fe can C, following the procedure in 

Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” and set up the calculation 

condition as shown in Figure 4.10.1. Click on Region_1 and set the composition 

as 100Fe-0C (wt%) and select Bcc as entered phase in “Select Phases” of 

“Settings for the Selected Region [Region_1]”. In Region_1, set the Diff. Length 

as 1E-5 mm. Click on Region_2 and set the composition as 99.85Fe-0.15C (wt%) 

and select Fcc as entered phase in “Select Phases” of “Settings for the Selected 

Region [Region_2]”. In Region_2, set the Diff. Length as 2 mm; 

 The Thermal History is at 1050 K for 1E6 seconds; 

 The total number of grids (# of Grids) is 100;. 

 The Thermal History is at 1050 K for 1E6 seconds; 

 In the setting shown in Figure 4.10.1, composition profiles at the initial and 

final stages, as well as at 1E3 seconds and 1E5 seconds, will be outputted. 

Click OK to perform calculations. 

 

Post Calculation Operation: 

 The calculated plot is shown in Figure 4.10.2. Enlarge the composition range 

between 0 and 0.5 (wt%) to clearly display Carbon composition. Add text and 

change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

Information obtained from this calculation: 

 Observe composition profiles of C and interface movement from  to  which 

indicates the γ -> α phase transformation. 
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Figure 4.10.1: Setting of the simulation condition 

 

 
Figure 4.10.2: Calculated composition profiles at 1050 K for 1E3 seconds, 1E5 

seconds and 1E6 seconds 
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Example 4.11 Fe-Si-C Uphill Diffusion 

Purpose: Learn to perform uphill diffusion simulation in a Fcc matrix at a constant 

temperature. 

Module: PanDiffusion 

Database: Fe-Si-C.tdb 

Calculation Method 1:  

 From menu bar click “Batch Calc-> Batch Run”, select Example_#4.11.pbfx. 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load Fe-Si-C.tdb, and select components Fe, Si and C, following the procedure 

in Pandat User’s Guide 3.2.1;  

 Select “PanDiffusion->Diffusion Simulation” or click the icon  to open a 

setting dialog as shown in Figure 4.11.1;  

 

 
Figure 4.11.1: A setting dialog with default settings. 
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 Select the units of the simulation from the “Options” dialog in Figure 4.11.2: 

 

 
Figure 4.11.2: Units applied in this example. 

 

 Click on “Select Phases” and make Fcc the entered phase, while other phases 

are suspended; 

 Click on Region_1 and set a uniform composition distribution of Fe-3.8Si-0.49C 

(wt%). The length (Diff. Length) of both Region_1 is 25 mm; 

 Click on Region_2 and set a uniform distribution of composition of Fe-0.05Si-

0.45C (wt%); The length (Diff. Length) of Region_2 is 25 mm; 

 The total number of grids (# of Grids) is 100; 

 The Thermal History is a period of 312 hours (13 days) with a constant 

temperature at 1050 oC; 

 The default output includes profiles of the initial and final compositions. To 

record a composition profile at a moment, click  next to the “Moments for 

Profile Outputs” and input a time value. As shown in Figure 4.11.3, profiles at 

100 hour and 200 hour will be outputted. Click OK to start calculation; 

 Details on these options can be found in Pandat User’s Guide sections 6.5.11 

and 6.5.12. 
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Figure 4.11.3: Settings applied in this example.  

 

Post Calculation Operation: 

 Set the scale of the Y axis to be 0.3-0.6 (wt%). Remove composition profiles of 

Fe and Si. The calculated plot is displayed in Figure 4.11.4. Add text and 

change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add grid to the graph by setting “Show Major Grid” True. 
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Figure 4.11.4: Composition profile of Carbon. 

 

Information obtained from this calculation: 

 Composition profile of carbon in Fcc Matrix after an uphill diffusion. 
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Example 4.12 Dissolution of a Single θ-Al2Cu Particle in FCC Matrix 

Purpose: Learn to perform single-particle dissolution simulation.  

Module: PanDiffusion 

Database: AlCu_MB.tdb 

Calculation Method 1:  

 From menu bar click “Batch Calc-> Batch Run”, select Example_#4.12.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load AlCu_MB.tdb, and select component Al and Cu, following the procedure in 

Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Dissolution Simulation” or click the icon  to open a 

setting dialog and select the proper unit of the simulation in the “Options”; 

 Click on “Select Phases” and make Fcc and AlCu_Theta the entered phases, 

while other phases are suspended; 

 In Alloy Composition set a composition of Al-1.55Cu (at%); 

 The total number of grids (# of Grids) is 100; 

 The Geometry of particles is set to “Spherical”; 

 In “Phase Information”, select Fcc as “Matrix Phase”. 

 To add a particle, click  bottom, then select AlCu_Theta in “Phase Name”. 

“Particle Size” is set to 3.0 um. “Vol. Fraction” is set to 0.008; 

 The “Thermal History” is a period of 35 minutes at 550oC; 

 Click OK to start calculation; 

 By default, dissolution simulation gives time-evolution of particle size as output. 

In order to display composition profile at desired moments, click  next to the 

“Moments for Profile Outputs” and input a time value. As shown in Figure 

4.12.1, profiles at 10 minutes and 15 minutes will be outputted. Click OK to 

start calculation; 

 Details on these options can be found in Pandat User’s Guide sections 6.6.11 

and 6.6.12. 
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Figure 4.12.1: Settings applied in this example. 

 

Post Calculation Operation: 

 The calculated particle dissolution with time is shown in Figure 4.12.2. User 

can modify it by changing the title, the scale and so on from the Property 

Window.  User can also add experimental data by clicking Table -> Import Table 

From Files, and select Example_#4.12.txt, and then follow Example 3.1 to add 

the experimental data on the plot. More information can be found in Pandat 

User’s Guide 2.3.1. 

 Click and open the Default table and select “distance”, “x%(Al)” and “x%(Cu)” to 

plot the composition profiles at starting, ending and the two selected 

intermediate times as shown in Figure 4.12.3. 
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Figure 4.12.2: The simulation result of particle-size evolution. 

 

 

Figure 4.12.3: The simulation result of composition-profile evolution. 
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Example 4.13 Multi-Particles Dissolution 

Purpose: Learn to perform multi-particle dissolution simulation. Two Al2Cu particles, 

with different sizes and volume fractions, dissolve into the Fcc matrix. 

Module: PanDiffusion 

Database: AlCu_MB.tdb 

Calculation Method 1:  

 From menu bar click “Batch Calc-> Batch Run”, select Example_#4.13.pbfx; 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load AlCu_MB.tdb, and select component Al and Cu, following the procedure in 

Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Dissolution Simulation” or click the icon  to open a 

setting dialog (as shown in Figure 4.13.1). 

 Click on “Select Phases” and make Fcc and AlCu_Theta the entered phases, 

while other phases are suspended; 

 In Alloy Composition set a composition of Al-1.55Cu (at%); 

 The total number of grids (# of Grids) is 75; 

 The Geometry of particles is set to “Spherical”; 

 In “Phase Information”, select Fcc as “Matrix Phase”. 

 To add the first particle, click  bottom, then select AlCu_Theta in “Phase 

Name”. “Particle Size” is set to 3.0 um. “Vol. Fraction” is set to 0.008; 

 To add the second particle, click  bottom, then select AlCu_Theta in “Phase 

Name”. “Particle Size” is set to 1.0 um. “Vol. Fraction” is set to 0.001; 

 The Thermal History is a period of 35 minutes with a constant temperature at 

550oC; 

 Click OK to start calculation; 

 Details on these options can be found in Pandat User’s Guide sections 6.6.11 

and 6.6.12. 
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Figure 4.13.1: Settings applied in this example. 

 

Post Calculation Operation: 

 The calculated particle dissolution with time is shown in Figure 4.13.2. User 

can modify it by changing the title, the scale and so on from the Property 

Window.  More information can be found in Pandat User’s Guide 2.3.1. 

 Add grid to the graph by setting “Show Major Grid” True. 
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Figure 4.13.2: Simulation result of particle-size evolution. 
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Example 4.14 Decarburization of Fe-C Matrix 

Purpose: Learn to perform decarburization simulation at constant temperature with a 

fixed activity at boundary.  

Module: PanDiffusion 

Database: Fe-Si-C.tdb 

Calculation Method 1:  

 From menu bar click “Batch Calc-> Batch Run”, select Example_#4.14.pbfx. 

Calculation Method 2:  

 Create a workspace and select the PanDiffusion module following Pandat User’s 

Guide 2.1; 

 Load Fe-Si-C.tdb, and select component Fe and C, following the procedure in 

Pandat User’s Guide 3.2.1;  

 Click on “PanDiffusion->Diffusion Simulation” or click the icon  to open a 

setting dialog and select the proper units 

 Firstly, click  of “All Regions” to delete Region_2; 

 Click on Region_1 and set a uniform composition distribution of Fe-0.5C (at%); 

The length (Diff. Length) of Region_1 is 100 um;  

 The total number of grids (# of Grids) is 100; 

 The Thermal History is a period of 10 seconds with a constant temperature at 

1000 oC; 

 The Lower Boundary Condition (left edge of Region_1) is a fixed “activity” of 

“a(C:graphite[*])=0.01”; 

 The default output includes profiles of the initial and final compositions. To 

record a composition profile at a moment, click  next to the “Moments for 

Profile Outputs” and input a time value. As shown in Figure 4.14.1, profiles at 1 

second and 5 second will be outputted. Click OK to start calculation; 

 Details on these options can be found in Pandat User’s Guide sections 6.6.11 

and 6.6.12. 
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Figure 4.14.1: Settings applied in this example. 

 

Post Calculation Operation: 

 Set the scale of the Y axis to be 0.1-0.6 (at%). Remove composition profile of Fe. 

The calculated composition profiles are displayed in Figure 4.14.2. Add text and 

change graph appearance following the procedure in Pandat User’s Guide 2.3.1; 

 Add grid to the graph by setting “Show Major Grid” to be True. 
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Figure 4.14.2: Simulation result of carbon composition profile 

Information obtained from this calculation: 

Decarburization process in Fcc phase in the Fe-C system. Lower boundary 

condition is a fixed carbon activity (0.01, Graphite as the reference state). 

 



PandatTM 2020 Example Book 

~ 157 ~ 
 

5 PanSolidification 

Example 5.1 Solidification simulation of Mg-Al alloy under specified cooling rate 

Purpose: Learn to perform solidification simulation of a Mg-Al binary alloy under 

specified solidification conditions using PanSoldification Module. Learn to use the 

features in PanSolidification Module.  

Module: PanSolidification 

Database: AlMg_MB.tdb; Mg_Alloys.sdb 

Calculation Method 1  

 Create a workspace and select the PanSolidification module following Pandat 

User’s Guide 2.1; 

 From menu bar click Batch Calc-> Batch Run, or click icon , then select 

Example_#5.1.pbfx; 

Calculation Method 2  

 Create a workspace and select the PanSolidification module following Pandat 

User’s Guide 2.1; 

 Load TDB file AlMg_MB.tdb through menu DatabaseLoad TDB or PDB or by 

click icon , and select the elements: Al, Mg.  

 Load SDB file Mg_Alloys.sdb through menu PanSolidification  Load SDB or by 

click icon , select the available alloys: Mg alloys, as shown in Figure 5.1.1.  

 Set Solidification simulation conditions as shown in Figure 5.1.2. The alloy 

composition is Mg-9wt.% Al. The cooling rate is 0.38 K/s is setting in Thermal 

History solidifying from 680 °C to 300 °C with 1000 second. Solidification rate 

is set as 50 μm/s. Please pay attention to the units of the time and length when 

set conditions.  

 Then Click OK to perform Solidification simulation. (Detailed description also in 

Pandat User’s Guide 7.2). 

 

 
Figure 5.1.1: Loading the MgAlloys.sdb file. 
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Figure 5.1.2: Set solidification conditions  

Post Calculation Operation: 

 The default plot presents the relationship between fraction of solid (fs) and 

temperature during solidification as shown in Figure 5.1.3.  

 The Default table contains many more calculated results: such as the 

secondary dendrite arm spacing in the arm_space column, the amount of 

Al12Mg17 phase in the f_tot(@Al12Mg17) column, and the composition of Al in 

the solid phase in w_S(Al) column. Users can create other plots from these data.  

 The evolution of secondary dendrite arm spacing during solidification is shown 

in Figure 5.1.4. 

 Experimental data can be imported through menu Table  Import table from 

File. The comparison of the calculated and experimentally measured Al 

composition in solid is shown in Figure 5.1.5.  



PandatTM 2020 Example Book 

~ 159 ~ 
 

 
Figure 5.1.3: Default plot showing fraction of solid as a function of Temperature  

 

 
Figure 5.1.4: The evolution of secondary dendrite arm spacing. 
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Figure 5.1.5: Comparison of the calculated and experimentally measured Al 

composition profile vs. fs in the primary (Mg) dendrites.  
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Example 5.2 Solidification simulation of an Al-Cu-Mg alloy for hot cracking 

susceptibility index prediction 

Purpose: Hot tearing or hot cracking is a serious defect occurred in welding and 

casting solidification. Cracking usually generated at the end stage of solidification 

along grain boundaries. Prof. Kou [2005Kou] proposed a criterion to describe the crack 

susceptibility by using a simple crack susceptibility index (CSI), which is the 

maximum value of |dT/d(fs)1/2| at fs
1/2 < 0.99. The CSI criterion has been successfully 

applied in several Al alloy systems. In this example, users will learn how to perform 

solidification simulation of an Al-Cu-Mg alloy and output the relationship of 

|dT/d(fs)1/2| vs fs
1/2 directly from Pandat, and thus determine the CSI value of the 

alloy. Users will also learn to set extra output tables with some specified properties 

and extra output plots from this example. Commercial database of PanAl.pdb 

including the thermodynamic and mobility data is required to perform the calculation 

of this example.  

Module: PanSolidification 

Database: PanAl2020_TH+MB.pdb; Al_Alloys.sdb 

Calculation Method: 

 Create a workspace and select the PanSolidification module following Pandat 

User’s Guide 2.1; 

 Load PDB file PanAl2020_TH+MB through menu DatabaseLoad TDB or PDB 

(Encrypted TDB) or by click icon , and select the elements: Al, Cu, Mg.  

 Load SDB file Al_Alloys.sdb through menu PanSolidification  Load SDB or by 

click icon , select the available alloys: Al alloys.  

 Set Solidification simulation conditions as shown in Figure 5.2.1; The alloy 

composition is Al-5wt.%Cu-2wt.%Mg. The cooling rate is 20 K/s is setting in 

Thermal History solidifying from 680 °C to 380 °C with 15 second. Temperature 

gradient is set as 10-3 °C/μm. Please pay attention to the units of the time and 

length when set conditions.  

 Set “Extra Outputs table”. Click the “Extra Outputs” in Figure 5.2.1, a new 

interface as shown in Figure 5.2.2 will appear. Click the blue “+” symbol in 

Figure 5.2.2 to pop out the Table Editor as shown in Figure 5.2.3. From this 

Table Editor, users can specify and type in properties to output, such as sqrt(fs), 

-T//sqrt(fs) in this example. -T//sqrt(fs) refers to -dT/d(fs)1/2, as the syntax // 

means derivative in Pandat software. Note that with this setting, a “generated” 

table will be created in addition to the Default table.  

 Set “Extra Outputs graph”. Click the icon “Graph” in “Set extra output” 

interface as shown in Figure 5.2.2, then click the blue “+” symbol to add extra 

Graph. An interface as shown in Figure 5.2.4 will appear. Select the “generated” 

table generated by the previous step. Drag sqrt(fs) from the left column to X axis 
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in the right column; drag -T//sqrt(fs) from the left column to Y axis in the right 

column.  Then click OK. Note that with this setting, a “graph” of -T//sqrt(fs) vs. 

sqrt(fs) will be plotted automatically in addition to the Default graph. 

 Then Click OK to perform Solidification simulation. (Detailed description also in 

Pandat User’s Guide 7.2). 

 
Figure 5.2.1: Set up solidification conditions 

 

 
Figure 5.2.2: Extra Output interface 
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Figure 5.2.3: Define properties in the extra output table. 

 
Figure 5.2.4: Define the axes of the extra graph. 

Post Calculation Operation: 

 The Default plot presents the relationship of temperature vs fraction of solid (fs) 

during solidification as shown in Figure 5.2.5.  

 The extra graph specified is plotted automatically as shown in Figure 5.2.6. 

 Rescale Figure 5.2.6. as shown in Figure 5.2.7. The hot cracking susceptibility 

index (CSI) is defined as the maximum value of -dT/d(fs)1/2 with  (fs)1/2 < 0.99.  
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Figure 5.2.5: Default plot showing the relation between temperature and fraction of 

solid 
 

 
Figure 5.2.6: Extra plot specified by Extra Graph setting 
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Figure 5.2.7: Rescale of Figure 5.2.8 showing the maximum point of -T//sqrt(fs) with 

sqrt(fs) < 0.99.  
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Example 5.3 HTC calculations in PanSolidification 

Purpose: Users have learned to obtain the crack susceptibility index (CSI) value of a 

single alloy under certain solidification conditions in Example 5.2. In this example, 

users will learn to use High Throughput Calculation (HTC) calculations to obtain a 

susceptibility index map in Al-Cu-Mg ternary system.  

Module: PanSolidification 

Database: PanAl_TH+MB.pdb; Al_Alloys.sdb 

Calculation Procedures  

 Create a workspace and select the PanSolidification module. Save the 

workspace in a user assigned folder different from the default workspace. The 

HTC calculation results will be saved automatically under this folder. (Detailed 

description also in Pandat User’s Guide 2.1) 

 Load PDB file PanAl_TH+MB.pdb through menu DatabaseLoad TDB or PDB 

(Encrypted TDB) or by click icon , and select the elements: Al, Cu, Mg.  

 Load SDB file Al_Alloys.sdb through menu PanSolidification  Load SDB or by 

click icon , select the available alloys: Al alloys.  

 Start HTC function through menu Batch Calc  High Throughput Calculation 

(HTC). 

 Choose calculation type from the drop-down list of HTC pop-up window and 

select “pan_solidification” as shown in Figure 5.3.1. 

 

 
Figure 5.3.1: Dialog to choose calculation type of HTC in PanSolidification 

 Define the compositional space for HTC simulation. The composition range is 

set to 0-5 wt.% Cu and 0-5 wt.% Mg, and mouse right click on the composition 

field of Al to set as the remaining composition, which is shown as -1 in all the 

composition field of Al, as shown in Figure 5.3.2.  

 Define the solidification conditions for HTC simulation. The same solidification 

conditions with cooling rate of 20 K/s and Temperature gradient is set as 10-

3 °C/μm, as shown in Figure 5.3.2. 
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 Set “Extra Outputs table”. Click the “Extra Outputs” in Figure 5.3.2.  The 

following extra output is defined as shown in Figure 5.3.3: time; T – 

temperature; w(*) – alloy composition; fs – solid phase fraction; sqrt(fs) – the 

square root value of the solid phase fraction; and -T//sqrt(fs) – the CSI index. 

Then click OK. 

 Set “Extra Outputs graph”. Using the procedure described in Example 5.2, click 

the icon “Graph” in “Set extra output”, set sqrt(fs) as X axis and -T//sqrt(fs) as 

Y axis.  Then click OK. 

 Click “Run HTC” button to perform HTC simulations. 

 

 
Figure 5.3.2: Dialog to setup compositional space and solidification conditions for 

PanSolidification HTC. 
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Figure 5.3.3: Define properties in the extra output table. 

Post Calculation Operation: Result Analysis 

 After all calculations have been finished, analyze the results through menu 

Batch Calc  Result Analysis. User can then analyze the results of the selected 

HTC calculation by opening the corresponding workspace as shown in Figure 

5.3.4. 

 
Figure 5.3.4: “Result Analysis” popup dialog to choose target workspace 
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 Define the criteria of the properties as filters for result analysis. As shown in the 

following Figure 5.3.5, analysis the “generated table”, set the condition to find the 

CSI for each alloy composition, i.e., CSI = MAX(-T//sqrt(fs)) at sqrt(fs)< 0.99. 

 

 
Figure 5.3.5: Criteria for Cracking Susceptibility Index setting from solidification 

results analysis. 

 

 After results analysis, a table which list CSI = MAX(-T//sqrt(fs)) for each alloy 

composition is generated as shown in Figure 5.3.6.  

 Select w%(Cu) as X-axis, press Ctrl then select w%(Mg) and (-T//sqrt(fs)) as Y-axis 

and Z-axis, respectively, click  on the tool bar to generate Figure 5.3.7 which 

shows the crack susceptibility map for Al-Cu-Mg alloys with cooling rate of 20 K/s.  

 The simulated result is comparable with the experimental results shown in Figure 

5.3.8. 
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Figure 5.3.6：A table which lists the CSI = MAX(-T//sqrt(fs)) for each alloy 

composition is generated after the results analysis 

 
Figure 5.3.7: Al-Cu-Mg crack susceptibility map with cooling rate of 20 K/s.  
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Figure 5.3.8: Experimental crack susceptibility test results. 
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